Configuration window appears out of the blue

Describe the bug
Periodically and out of the blue (a few times a day) the Configuration window suddenly pops up on the screen, and must be closed. Often as you're clicking or typing this means changing by mistake some BTT configuration. Has been like this since Catalina at least, and persists on Big Sur.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
None I guess. Checked for configs over and over to see if this was configured by mistake. But happens either in regular (touchbar) or clamsheel (no touchbar) modes.

Screenshots
Not needed.

Device information:

  • Type of Mac: MBP 2018 15 in
  • macOS version: 11.1 (but since at least 10.15)
  • BetterTouchTool version: 3.505

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Happy to provide some sort of log if instructed how.

Most likely somewhere in your BTT setup an trigger with predefined action "Show BTT Preferences" is configured.
If you want you can send an export of your preset (andreas@folivora.ai), then I can have a look!

Hi Andreas,

ich habe auch das Problem. Ich habe dir gerade per Mail meine exportierten Presets geschickt.

I have the same issue on two different Macs (one MBP, one iMac w/trackpad). It started after I upgraded to Big Sur. The configuration window appears in the foreground several times a day and has to be dismissed.

Weird, are you all using the GoldenChaos preset?

I am not using GoldenChaos. I only have about fifteen triggers set up, so I may try to delete & reinstall BTT and see if that fixes the problem. (Which is still ongoing. The configuration window appeared while I was replying to this thread.)

Having this issue and not using GoldenChaos. Started after I upgraded to Big Sur.

I too am seeing this only on one user account, but not the other user account. On the same user account I am also unable to use the multi finger swipe on tb to adjust volume or brightness. Both issues are only on one user account, which is using a preset I created and exported so all settings are the same. This behavior started on Big Sur.

Imprint | Privacy Policy