Trackpad gestures not working after waking up Mac from sleep

I have the MacBook Air 15" M2 (2023) and I noticed that when I let my computer go to sleep and come back to it, none of the custom gestures would work.

What's odd is that doing one of the following would make it work:

  • I restart BTT
  • I check for updates (alpha or regular), but not even actually update

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

could you check whether version 4.307 helps with this issue?

Hey Andreas! First of all, THANK YOU so much for all your work on BTT! I've been a customer since 2016 and this app is always first thing I install on all my Mac devices. Couldn't live without my custom BBT commands.

That said, I've been experiencing the same issue reported in this thread since the Beta release of OS Sonoma (July 2023 of this year). The issue is that for some reason, even though BTT is still running in the background, after a sleep/wake combo the tool will sometimes stop working and I'll need to restart or re-open BTT in order to get my custom triggers to work again.

I initially figured it was an issue with the Sonoma Beta as I had other tools also break during the Beta, so I used the workaround of restarting BTT whenever my computer wakes and didn't bother following up even though it was inconvenient. However, after the many OS and BTT updates (I'm on version 4.308 right now) since July 2023, I'm still experiencing the issue and it's been bothering me enough that I went to search for some solutions. I'm so glad I found this community and to see you so active here! I wanted to make sure it was filed as a bug and hopefully prioritized - happy to provide any details you'd need to help debug!

Describe the bug
MacBook Trackpad custom triggers stop working when Mac wakes from sleep (or I just go away for a bit and come back to wake the screen). None of my custom actions run anymore, even though I see BTT still running in the background. It's not until I physically open BTT or restart the app that it begins to work again.

  • I've tried toggling the 'Restart BTT after wake from sleep' button but have experienced the issue both when the toggle is enabled and when it's been disabled.
  • I've tried re-installing BTT and activating my license without any success
  • I've installed the Process Priority Helper Tool (and it confirms it's active)
  • The issue is also a bit hard to 100% repro - if I force my Mac to sleep by closing my lid and opening it right back up, sometimes BTT will continue running. But other times it stops and I have to restart BTT. I haven't been able to pinpoint the exact conditions to trigger the issue, but it always happen when I am waking my computer from sleep or I've gone away from the screen for awhile
  • One note that might help with investigations: Sometimes (and only sometimes! Not sure what's triggering it) I'll have BTT raise the popup warning that I need to go into my Privacy & Security settings under Accessibility to enable BTT. Each time my BTT is already enabled in the settings, but I'll go ahead and toggle it on and off. Still get the issue either way.
  • I am connected to an external monitor, but having this issue whether or not I'm connected.
  • I only have 3 Finger actions set up for my triggers

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

MacBook Trackpad - configured with 3 Finger actions

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

No screenshots available, I can try to take a picture of the popup that asks to enable permissions if needed.

Device information:

  • Type of Mac: 2021 MacBook Pro with M1 chip
  • macOS version: Sonoma 14.2, but the issue has been happening ever since the first Sonoma public beta in July 2023
  • BetterTouchTool version: Currently on 4.308, have always been in the alpha channel, been experiencing this issue since July 2023.

Additional information (e.g. crash logs, related issues, etc.):
The custom gestures I have set up and that are breaking are:

  • 3 Finger Click
  • 3 Finger Swipe Left
  • 3 Finger Swipe Right
  • 3 Finger Double-Tap
  • 3 Finger Swipe Up
  • 3 Finger Swipe Down

I also searched through the forum I found a few other threads of folks with similar issues that I've compiled for you below, hoping we can track it all in one thread as it's the same issue.

Many thanks Andreas!

Edit: Just saw your thread over here (custom snap areas disappear, requires BTT restart - #6 by Dirk) that looks to be tracking similar issues with deep sleep issue! Unfortunately, I am on 4.308 already and still experiencing the trackpad issue. I don't use custom snap areas but expect it's the same root cause that requires a BTT restart.

The trackpad issue could be different, but maybe it's related. If you still encounter this with 4.308, please go to Help => Export Diagnostic Debug Information and send the result to The logs might tell what's happening.

1 Like

Exactly same issue as @Stinky, except I have the BTT popup warning that I need to go into my privacy settings appears each time I come back to my computer if I left it for quite some time (more than 30min). The fact that I close the display or not doesn't seem to change the behavior of the bug.
Note : I am on 4.308 already

@sud, BTT only shows the privacy window it it doesn't have access to the Accessibility API. This would also explain your gestures not working (most of BTT's actions require that API).
It is possible your privacy database is corrupted, this unfortunately sometimes happens due to a macOS bug.

You can reset the database by running this terminal command. Before running this make sure you don't have any unsaved work, also quit BTT before running this.

sudo tccutil reset Accessibility

After that you will need to add all apps to the Accessibility section in System Settings => Privacy & Security again. However this often fixes permission related issues.

Hey Andreas, just coming back to report that I haven't had any issues with this since updating last week. Thanks!