After sleep, global touchbar widgets are not visible


#1

Describe the bug
The issue: after waking up from sleep, BTT does not take control over touch bar (it's not visible initialy, and if i'm using CMD modifier it shows the widgets, but not permanently)

What am I doing to achieve what I want now: Pressing shift and CMD modifiers after each wake up. For some reason, after I do that BTT takes control of the strip and i can see even the widgets that are set up to be visible without any modifier.

What would be great: If I hadn't had to press shift and CMD for BTT to take over the control over the strip.

It's been happening for a while now, so it's not an issue caused by some recent, particular update.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touchbar

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macbook Pro 13" Mid-2017 16GB
  • macOS version: 10.13.5
  • BetterTouchTool version: 2.530

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.


BTT does not start after awake from sleep
BTT keeps shutting down multiple times during the day
BetterTouchTool stops working in macOS 10.14 Mojave
Keep custom touchbar always on
#2

Weird, in general BTT should save the last state before sleep. I'll try to reproduce this here!


BTT sometimes does not take over the Touch Bar after waking from sleep
#3

For what it's worth, I haven't been able to find any consistency to this issue. I guess that isn't worth much :stuck_out_tongue: if I notice a pattern, though, I'll post here.


#4

bump any update on this? I'm still seeing this bug on a daily basis when waking my Macbook Pro from sleep.


#5

I'm also having this problem. 2018 15" MacBook Pro on the Mojave Public Beta builds. Restarting BTT gets it going again.


#6

I am also having this issue with many of my "Run AppleScript & Show Return" widgets. After my computer has been asleep, the AppleScripts do not run, and instead vanish completely (see screenshot below). Restarting BTT fixes this, but it's annoying to have to restart every time...

Problem (Widgets on right side):

What it should look like (right side):


#7

Possibly the apple scripts return an empty string right after sleep thus hiding the widgets? (I think your issue is different from the others though, in the other cases the BTT Touch Bar doesn't show up at all).
BTT automatically restarts itself right after sleep to reinitialize, so it's kind of weird that another restart fixes it. If you have a preset that can reproduce this issue it would be great if you'd post it or send it to andreas@folivora.ai


#8

You may be right, I've also noticed that this seems to occur specifically when the computer has been asleep for a long time, activating Hibernate mode on the mac. Is it possible this somehow interferes with the AppleScripts? This didn't occur before the 2.6xx update... I'll email you my preset in case that helps. Thanks!


#9

This is what I'm finding now; if my computer is asleep for a short time, BTT comes back with no problems, but if it's been asleep for more than a couple hours (it seems), I have to manually restart it.


#10

seems to be asleep more than 10 mins for it to fail to show for me.


#11

I was experiencing this issue as well, but I've probably found the hotfix through BTT auto-restart macro (in the "Other" tab) after the wake.

Check the screenshot below:


#12

Thanks to your solution 007hacky007 I was able to find a workaround.

In my case, I created a new named trigger force_touchbar_visibility which will run action toggle btt touch bar twice - which will basically reenable it. Then I've attached it to after mac wakes from sleep and after booting on mac with serial number actions.


BTT TouchBar becomes disabled after sleep
#13

Really weird, that should basically be what BTT does anyways.

I still haven't been able to reproduce the issue on my machines unfortunately. Do you know whether BTT restarts correctly after sleep on your machines?

I have added some more logs to the latest release, it would be great if somebody who encounters the problem could send me the debug info (About Tab => Export Debug Info), maybe the logs show why the touch bar won't show up.


#14

I'll send you debug info on the mail


#15

Periodically happens to me as well.


BTT TouchBar becomes disabled after sleep
After Sleep BTT TouchBar becomes disabled and individual gesture/trigger settings get messed up
BTT TouchBar becomes disabled after sleep
#16

This is happening to me as well after upgrading to Mojave.


#17

Happens on Mojave and unfortunately it sometimes happens also after the hotfix I posted before.
Actually this is so annoying, I wonder whether to upgrade BTT from trial to regular version once the trial ends. :frowning:


#18

Yeah, same :frowning:

BTT is otherwise perfect but it does get quite annoying having to constantly restart the app. Here are some more details to hopefully diagnose the issue:

OS Mojave 10.14

Hardware MacBook Pro 15in 2018

BTT Version BTT 2.538 (this happened on stable builds as well)

The issue: BTT would not initialize after long periods of sleep, even with the hotkey. I haven't timed it but I would say after the macbook's been asleep for more than 45 minutes, the default Apple Touch Bar takes over and the only fix is to manually restart BTT. The Hotkeys to reinitialize BTT after wake does not work either.


#19

Have you tried this solution?

In my case, I created a new named trigger force_touchbar_visibility which will run action toggle btt touch bar twice - which will basically reenable it. Then I've attached it to after mac wakes from sleep and after booting on mac with serial number actions.

For me, this issue no longer exists when applying those.

JSON for named trigger:

{
  "BTTTriggerType" : 643,
  "BTTTriggerTypeDescription" : "Named Trigger: force_touchbar_visibility",
  "BTTTriggerClass" : "BTTTriggerTypeOtherTriggers",
  "BTTPredefinedActionType" : 188,
  "BTTPredefinedActionName" : "Toggle BetterTouchTool Touch Bar",
  "BTTTriggerName" : "force_touchbar_visibility",
  "BTTEnabled2" : 1,
  "BTTUUID" : "424D4869-54D6-4F73-8057-D57241A20D8E",
  "BTTEnabled" : 1,
  "BTTOrder" : 10,
  "BTTAdditionalActions" : [
    {
      "BTTTriggerType" : -1,
      "BTTTriggerClass" : "BTTTriggerTypeOtherTriggers",
      "BTTPredefinedActionType" : 188,
      "BTTPredefinedActionName" : "Toggle BetterTouchTool Touch Bar",
      "BTTEnabled2" : 1,
      "BTTUUID" : "25D68F11-9C11-4BD1-840E-E6307607210D",
      "BTTEnabled" : 1,
      "BTTOrder" : 0
    }
  ]
}

JSON for "launching on mac" action in others tab:

{
  "BTTTriggerType" : 641,
  "BTTTriggerTypeDescription" : "Launch on Mac with Serial Number: C02WV0PGHV2Q",
  "BTTTriggerClass" : "BTTTriggerTypeOtherTriggers",
  "BTTPredefinedActionType" : 248,
  "BTTPredefinedActionName" : "Trigger Named Trigger (Configured in Other Tab)",
  "BTTNamedTriggerToTrigger" : "force_touchbar_visibility",
  "BTTMachineSerialNumber" : "HIDDENFOROBVIOUSREASONS",
  "BTTEnabled2" : 1,
  "BTTUUID" : "CF2E5CC9-E237-4305-B68F-1AB8562DDD9F",
  "BTTEnabled" : 1,
  "BTTOrder" : 11
}

:point_up: in this one you'd have to change the serial number to the one you have under Apple > This mac > General > Serial number

JSON for "after mac wakes up from sleep"

{
  "BTTTriggerType" : 606,
  "BTTTriggerTypeDescription" : "After Mac Wakes From Sleep",
  "BTTTriggerClass" : "BTTTriggerTypeOtherTriggers",
  "BTTPredefinedActionType" : 248,
  "BTTPredefinedActionName" : "Trigger Named Trigger (Configured in Other Tab)",
  "BTTNamedTriggerToTrigger" : "force_touchbar_visibility",
  "BTTEnabled2" : 1,
  "BTTUUID" : "E3CCA5AF-D198-45CB-BB09-839301E9BC76",
  "BTTEnabled" : 1,
  "BTTOrder" : 8
}

Let me know if it works for you. Andreas mentioned that he couldn't reproduce the issue, so in the meantime this might be a good workaround :slight_smile:


#20

Hey all. Not sure If I can be any help. Happy to send logs, but not sure if it will show anything.
My issue is very similar, but slightly different. My main BTT Touch Bar does not show up at all. I get the standard OSX buttons. Doesn't matter if I restart BTT or the Mac. Even deleted my preset and uninstalled and reinstalled. No dice. However, my secondary functions do show up, so if I hit CMD or Option. Those menus show up on the touch bar. But then when I release them, It goes back to the standard (OSX) buttons for whatever app I'm in.
Cheers.