After sleep, global touchbar widgets are not visible


#21

I've tried that, it doesn't work for me.
BTT almost never shows up after my Mac's been asleep for ages. I've set a keyboard shortcut to toggle the touch bar twice and am now in the habit of just pressing it when I wake my mac. Don't know why it won't happen automatically using the 2 named triggers you mentioned.


#22

@Worie I saw that thread too and unfortunately those scripts doesn't seem to help. It'll trigger after short periods of sleep, but anything more than an hour or so and BTT just seems to be disabled. The default Touch Bar comes up, and the BTT preferences doesn't seem to indicate that the Touch Bar is hidden either.

I wonder if it has something to do with my MacBook preferences. I double checked BTT Accessibility preferences, even deleted it and re-added it after upgrading. I also checked currently have PowerNap disabled, maybe that's causing something?


#23

Sure, I just suggested it, cause it's working for me. I've my PowerNap disabled too, but enabled hard drive sleep and screen dimming. In keyboard preferences, I've set that TouchBar strip contains: application tools (i don't really know the translation in english, my system settings are not in english). I'm not sure if there are any other settings that may affect this...

One more thing that you could try @dongju would be to change the trigger action that I provided to "restart BTT" action, only once.


#24

It would be great if you could try v2.639 alpha .
If it still doesn't work with that version, try to check this option in the General Touch Bar settings:


#25

Just updated to v2.639 alpha and checked proposed checkbox. Also removed my "Other" actions trigger by Mac wake up I set earlier to fix that (unfortunately it did not do the trick as longer sleep still broken things up).

Will report back after few hours/days. Hopefully it will do the work.


#26

It's still not working. My MacBooks slept 3 times since updating and checking that box. BTT Touch Bar still isn't showing up when it wakes up.


#27

Very weird ;-(
If that checkbox is checked BTT definitely tells the system to show the Touch Bar, I'm a bit out of ideas why that wouldn't work on some systems.

Does this also happen when you restart BTT via the BTT menubar menu, or really just after sleep?


#28

Hey, getting the same issue here since I updated to Mojave. Happens to me about 50% of the time after sleep, seems to be more often when sleep lasts longer. Doesn't happen when restarting BTT via the menu, only after sleep for me.


#29

Just after sleep.

Though I've noticed that sometimes after restarting the computer BTT Touch bar will load but scripts won't run. In those cases, sometimes restarting BTT fixes it, other times I have to restart the computer again to have the scripts run. Think that's a different issue though. I'm waiting for it to happen again to send you a debug file and screenshot.


#30

Just for the sake of leaving the info - for me, it seems to be working even without this checkbox checked as of 2.639 alfa


#31

Getting back to this.

The v2.639 alpha with proposed checkbox fixed that for me. At least I did not experience the problem since my last message here and also I had the Macbook in the sleep multiple times (for several hours as well - and such long sleep always broke it before).

So yeah, solved for me. Thank you!


#32

i am still seeing this issue on the newest alpha with the button checked. ill try without it checked and report back!


#33

I think it may have stopped happening for me. My Macbook's now woken up 4 times without any issues in BTT.

Edit: Spoke too soon. Had to disable/enable when I got home from work tonight.


#34

Unfortunately issue came back in 2.639 when updating to Mojave (after long sleep, btt touchbar did not activate by itself) :frowning: Just bumped to latest stable, we'll see if that helped anyhow

edit: it seems updating to 2.641 made it working again


#35

I'm also having this issue right after updating to #mojave Damn it, this is what I get for ignoring common sense and updating right on release...

I have to restart BTT in order to get the touchbar back.

If I set the computer to sleep manually, the touchbar seems to behave as it should, although there is a long delay before it replaces the default one.

Device information:

Type of Mac: Macbook Pro 15" 2017
macOS version: 10.14
BetterTouchTool version: 2.641

#36

Hi all. Currently on 2.641 on Mojave 10.14. The new checkbox in the preferences unfortunately made no difference. Touch Bar reverts back to the stock Touch Bar after waking from sleep.


#37

Just wanted to chime in and mention I am also experiencing this on Mojave 10.14. Seems BTT does not show particularly after a longer period of sleep. Have to restart BTT to solve.


Touch Bar in Mojave not working after sleep
Touch Bar in Mojave not working after sleep
#38

I tried a lot to reproduce this but have been unable to do so on any of my machines ;-(
Could any of you check whether in Activity Monitor a process called BTTRelaunch is running? (That's responsible for restarting BTT after sleep)


#39

i am seeing it on my machine!


#40

EDIT: Nevermind it's there running, but I still have the issue as well :confused: