Work in progress and alpha features

Mind if I bring attention to this? As the AQT userbase continues to expand, loading widgets appearing everywhere on startup or group-enter creates a bad "glitchy" impression to the users. Would be great if this is a reality!

1 Like

@Andreas_Hegenberg PLEASE this.

@Andreas_Hegenberg working with the new context menu tools right now. Is there a way to add disabled plain text as well as keyboard shortcut annotations? A la how Mission Control Plus shows its version number/keyboard shortcut for Quit/etc:

Screen Shot 2020-06-26 at 8.01.42 PM

My current menu:

Screen Shot 2020-06-26 at 8.03.08 PM

I honestly think a new section for menubar items should be in place, will take more time to get things working of course but just as apple demonstrates with wwdc 20, better late but good than early but gimmicky

Ping me if you need an icon or UI advice for it!


Is there a way to paste copied conditions without overwriting current conditions? I have a set of like 30 conditions to add to three other conditional activation groups...

1 Like

H Andreas! Absolutely love this Tool. I am having a lot of crash issues and the Touch Bar keeps disabling itself out of nowhere, even without any modifier keys being pressed. I am installing the Alpha updated now. I hope this works because I only have one day left on my trial and I reeeeeaaally want to keep using BTT. fingers crossed

Still need a little help with this issue...

It's been messing up the controls in AQT for many users

Before it might have been trial & error, but in macOS 11 this gets weird. The Top Margin does not have any effect at all anymore on the display, 0, 9 or -9 have the same result. :frowning: Widget being the one on the right of the battery.

would just like to link this here:

1 Like

Hi @Andreas_Hegenberg, I have updated to the latest 3.400 version, but still the Environmental Variables of menubar item cannot be modified programmatically via the update_trigger method. :joy:

var updateDefinition_mb = {"BTTAdditionalConfiguration" : newConfig_mb};
callBTT('update_trigger', {uuid: MB_uuid, json: JSON.stringify(updateDefinition_mb)});

Hi @Andreas_Hegenberg, can you add the following settings to the clipboard Touchbar widget?

  • Clearing items older than [user set value in minutes or hours]
  • Max items (disabled by default, but with a value of something like 30 when first enabled)
  • Show a clear all button (allows clearing everything including current clipboard content but favorites)

Thank you for considering, and regardless, thank you so much for such a great tool! BTT is very handy, I love it.

hello, @Andreas_Hegenberg i have the purchased version that will forever update lol. i have two requests and i literally created this profile to ask this!
for Touch Bar:

allow media (now playing widget) to be active. by this i mean that if the text is too long, that it will move constantly so that you can read the whole thing. kind of like how cars do it. this will allow us to make the buttons smaller
allow widgets to move to the right or left by swiping within that widget. Reason: if i want to swipe the now playing widget to skip song or rewind song. this would avoid people needing to add 2 extra buttons
thank you! let me know if it can become possible or if its already possible now !

Applescript results missing icon. I have a preset I created and posted here (K2 Coronavirus) the main icon normally displays an Icon before and after script is run. Since latest update, that icon is missing after script runs and data is displayed.

return "{icon} " & Country & " Cases " & CoronaVirus

I think I haven't touched the Touch Bar code in the recent versions.
Did anything else change? (e.g. macOS version?)

There was an update to MacOS - 10.15.6, wonder if that caused this issue?

This code has not changed. return "{icon} " but the icon is not displayed.

Results returned looks correct to display the icon assigned.
{icon} USA Cases

Does it show the {icon} placeholder on the Touch Bar or doesn't it show anything where the icon should be?

Shows no icon or placeholder. When placeholder is removed from code, the icon is shown (centered left like normal), not where I am placing it on line 1

I just tried to create a script that inserts a icon using the {icon} placeholder but it still seems to work fine here :-/
Can you reproduce this with any Apple Script widget? Are you sure it's not black icon on black background or something like that?

I haven't installed the supplemental update to macOS yet, will do that this night.

Looks like its the color. The icon is there, but its black. font color setting set to white. Icon does show white when visible before script runs, then turns black.

I colored background of button and bingo, I see it, but its not colored.



I think this has always been like this (there was no easy way to automatically change the color for icons when inserting them into a title, thus I didn't implement it).

Are you sure this worked before with the black icon?