Shortcut sending not working with Microsoft Remote Desktop 10

Describe the bug
I set up 3 finger swipe down for keyboard shortcut "Crtl + W" (or ^ W). When I trigger it in Microsoft Remote Desktop 10 client, it triggers successfully (I have feedback setup as well), but only the key "W" goes through. So each 3 finger swipe down results in typing a "W" instead of closing the current tab (via Ctrl W).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Trackpad

Screenshots
See my config here:

Device information:

  • Type of Mac: MacBook Pro (15-inch, Late 2016)
  • macOS version: 10.15 Beta (19A487l)
  • BetterTouchTool version: v3.086

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I looked up this issue and found this Github issue which indicates it should be fixed by v2.353. I'm running v3.086 and have enabled "Shortcut sending compatibility mode", but am still not able to get it to work.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Did you find a solution?

I use BTT 3.401 and the issue is still here.

P.s. I have to use Karabiner-Elements for those shortcuts, but I prefer to configure BTT instead of Karabiner.

Still experiencing this same issue.
I used to love BTT when I had my old mac. I spend much of my day working in Amazon Workspaces doing development for work. Therefore, I bought a new BTT license with the goal of creating many automations that would help my workflow.
However, I am experiencing the same issue as described above, namely that modifier keys are not passed through to the remote machine.
e.g.
two finger tip-tap-right mapped to Ctrl-C only passes in "C". This is the same issue with all modifier keys.
It seems that the same bug has been opened for many different remote desktop applications and use cases. See below:

  1. BTT and Microsoft Remote Desktop
  2. BTT not working with new Microsoft Remote Desktop
  3. Microsoft Remote Desktop 10 mouse button shortcuts not working
  4. .....................bettertouchtool-does-not-work-with-amazon-workspaces/1874/5

I am using BTT Version 3.504 on a MacBook Pro 16 inch on macOS Big Sur 11.1 and connect to a Linux Amazon Workspace. My modifier keys work in my linux workspace when pressed on the keyboard.

Squashing this bug or providing a workaround would be really appreciated.

Thank you!

unfortunately it’s a bug in the remote apps which don’t handle programmatically created events.

For some problematic apps you can workaround it by sending the modifier keys explicitly:

For others enabling the "Shortcut Sending Compatibility Mode" can help:

But some seem to ignore pretty much all programatically generated modifier events (Karabiner Elements works because it works at a much lower level than BTT)

Thanks for the quick response and explanation. Unfortunately, neither of those two workarounds solved the problem for me. Out of curiosity, why is it able to send the non-modifier keys if it's unable to handle programmatically created events?

Is there something else going on in addition to this perhaps? It seems that windows machines can pass modifier keys to remote windows machines which makes it sound like not an app issue?

Yes, I think they handle programatically generated modifier keys differently for different operating systems, but unfortunately I have no idea what is the logic behind it ;-(

I think I might have found some obscure way to send the events in a way that is handled correctly by at least the Microsoft Remote Desktop :-). I'll need to do more testing though as it's currently pretty fragile.

Imprint | Privacy Policy