Microsoft Remote Desktop 10 mouse button shortcuts not working

Describe the bug
I use BTT to send a shortcut (control-8) to Microsoft Remote Desktop 10.1.8 when I press a mouse button (button 4). The CAD program running on the connected PC does not register the key combination when sent by BTT but does if I use the keyboard. This problem did not exist on MS Remote Desktop 8.X.X that I used successfully for several years.

*Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Logitech mouse.

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2015 27" 5K iMac
  • macOS version: 10.11.6
  • BetterTouchTool version: 2.513 (850)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I have re-started the both MRD and BTT several times and tried deleting the app from the BTT list, and re-doing the shortcut several times as well as trying the shortcut with compatibility mode on and off.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

I experience the same problem. It seems like modified keys are not received correctly when sent thru BTT. For example, the Chrome browser on Windows will do a refresh for cntl-shft-R and if you physically use those keys the refresh works just fine. But if you define a touchbar button in BTT to send that, it doesn't work. I tried it as a "custom keyboard shortcut". I also tried as a "predefined action" with modifier keys down, then R, then modifiers up. For sending something like Alt-1 I tried those methods and also the Type/Paste custom text Utility action and that didn't work either. Somehow, BTT is not sending in a way that is EXACTLY the same as when I physically use the keys.

BTT 2.551 on 2016 MBPro 13" w/ touchbar running MacOS 10.13.6 and Microsoft Remote Desktop 10.2.1 connecting to Windows 10.

I'm also having non working Touch Bar custom buttons now when I upgraded from RDP 8 to RDP 10.

I'm on a 2017 MacBook Pro 15" with the latest version of MacOS 10.13.6 and on BTT 2.536.