GoldenChaos-BTT Support and Feedback Thread

I downloaded 3.111, but it seems that the icons are still swapped. Is there something to be done on the end user side, or is this a wait until it's fixed thing?

Sidenote, the Sparkle updater does not work when switching to the alpha branch from latest stable. Thinks that it is downgrading and exits.


1 Like

I'll be working on the next experimental version tomorrow - if the icons are still swapped, I'll swap them back manually in the next version.

Hi GoldenChaos,

thank you for your effort you put into your super preset!

I noticed that my F1, F2, F3, etc. keys don't show up when I press and hold the fn key.
Is there a fix to this?

There's another thing I noticed:
Every time I boot up weather data can't be fetched until my VPN connects.
So after I connected I always have to "Command + Option + Shift + P" and turn the weather off and on again to fetch weather payload.
Is there something like a workaround, e.g. pressing the icon to fetch data again?

Warm regards

Unfortunately there is no way to use the fn key with bettertouchtool, so sadly that key becomes useless :confused:

As for the weather widget, @Andreas_Hegenberg would be able to help with that!

Hi- fantastic work!

I have a couple feature requests:

An option to turn off the fullscreen button when Use Normal Escape Key is on.

A button for Screen Saver in the control menu.

A way turn turn off buttons I don't use in the option and control menus/toggle text labels (as in, I don't want any!).

Again, excellent work. Thank you!

1 Like

I like all those suggestions. I’m on it :smile:

Re: Disabling the fullscreen button. I wanted the same thing and found a way to disable it and just use the esc button by doing the following.

  • Select "Use normal escape key" in GC-BTT settings.

  • Bring up the main BTT configuration window and click 'All apps' on the left hand list.

  • Scroll down to the 'Home Strip' category and select the 'Fullscreen' button.

  • Now on the right hand configuration options, uncheck 'Enable/Visible on Touch Bar'

Yes it is true. I've noticed that too. maybe it is a bug or whatever but we can fix it easily, we need the set of icons for the weather, @GoldenChaos or @Andreas_Hegenberg why don't you post this icons set? please? so we can fix it by ourselves....thnaks/.......:wink:

if I can add some suggestions I would say also to add the "shut down" would be very helpful....

@Tony90 You can add a shutdown button to the GoldenChaos config fairly easily. I added and tested it out just now. I elected to put the button under the Control Strip (hold ctrl to view).

  • Open up the BTT config (not GC config) and hit 'All Apps' at the top of the left column.
  • Scroll down under 'Groups & Top Level Triggers' until you see the section labeled 'Control Strip (Hold ctrl to view) and click that text.
  • Under the Edit menu, click "Add new trigger"
  • In the new window that pops up on the right, select 'Touch Bar Button'
  • Now on the right hand configuration you can customize how the button will look. In the icon section you can actually search for 'power' and pick the power icon you prefer. Alternatively, just type 'Shutdown' under 'Button Title' to have it display text instead.
  • On the right hand config in the 'Item Placement On Touch Bar' section, click the left most icon.
  • Under 'Modifier based visibility, select 'Only show while all these modifiers are pressed' and check off '^ctrl' only.
  • Click the big + button where it says 'Assign First Action...'
  • In the new window that pops up, expand the 'Controlling Other Applications' section and click 'Run Applescript (async)'
  • Paste in this code:

tell app "loginwindow" to «event aevtrsdn»

  • Hit save. You should now see a shutdown button in the touchbar when you hold down the ctrl button.

Notes: this will bring up the standard system dialog asking if you want to shutdown your computer. If you would like to immediately tell the system to shutdown without dialog, use this Applescript instead..
tell app "System Events" to shut down
(I did not test this though)

hey man you are a "pro".....I tested both buttons (shutdown directly and with the system dialog) and they work perfectly.....chapeau!!!!!! :+1:


I just got a pair of AirPods and the "Connect to AirPods" button works perfectly! Thanks for this!

One thing I am having trouble with is the media controls. I would say that 9 out of 10 times I try to play or pause some audio it fails. Any ideas?

1 Like

Enjoy those AirPods, man!

I'm not sure about the play/pause button. What version of GC are you using?

@GoldenChaos I'm using 3.065-4 .

Hello, I'm new to the forum. I really like all your realizations and especially the colapse bar.

Currently, I'm trying to modify the apple script for the Date / Time widget.

I would like to display the date on two lines, like this:

I can't find the solution to force the line break....

Thank you in advance for your help!

1 Like

I just upated to the newest version and wanted to say thank you for your great work!
Since I updated I don't see any calender information on the Touch Bar. You've noted, that you switched to the native plugin integrated in BTT. BTT has access to my calender. Does anybody have an idea what the problem could be?

1 Like

@bowlingkopp Can you paste a screenshot of your Touch Bar?

@Tibo in the BTT config for the widget, you literally just type the formatting with the line break and it should work as shown in the screenshots below. However, GC-BTT automatically controls the date format, so in order to preserve your date format you should not resize the menu bar. In the future I'll add a way to customize the GC-BTT date format :slight_smile:

@rctneil so sorry for the delay here. I'm genuinely stumped. I can't reproduce this issue, nor can I find anyone else with the same issue. Are you still having the problem? @Andreas_Hegenberg would you happen to know why his media keys would not work to control media?

@GoldenChaos No worries about the media playback. I'll keep investigating. One major issue is that in the latest experimental version, I find that BTT every now and again says "You have not yet configured actions in BTT". I've removed the preset and reconfigured it for the 3rd time in two days about half an hour ago and now it's back to saying that. Could be due to the machine sleeping and waking up again but it's really annoying. Any ideas?

I know the answer to this one! It was reported in another thread. A BTT regression caused this switch to be flipped for some users. The fix is to re-enable BTT from the menu bar menu here:

Let me know if that works :slight_smile:

@GoldenChaos . Unfortunatley not in this case. It's fully enabled. The Touch Bar just has a large button that shows "You have not yet configured actions in BetterTouchTool".

If I delete the preset and redownload it then it works but 30 mins later it will disappear again!

Also, I have noticed a lot of bugs in the last few versions eg:

  • Two options in settings have a funny red background across their bar.
  • Certain items toggle switches don't slide. They work but don;t indicate whether they are on or off.
  • When upgrading and restoring settings it gets everything wrong.
  • Also the badge items are always set wrong after an upgrade. Some are correct but not all. The majority are switched on when I ahve previously turned the majority off.

Please don't take all this negatively. These are just my experiences and by me bringing them up, they can hopefully get fixed and make it better for everyone! This preset really makes the Touch Bar worth using!

I appreciate your hard work on the preset and @Andreas_Hegenberg hard work on BTT itself!

1 Like