GoldenChaos-BTT Support and Feedback Thread

feature-request
bug

#1282

Definitely a bug, I need to fix how it hides/shows the home strip in general, and it's not working as intended inside widget groups as well. Thanks for pointing this out, I hadn't noticed it before!

EDIT: Shoot, I forgot that fn is not selectable as a modifier. Hrm. @Andreas_Hegenberg I may need some help here...


#1283


This is what I see no matter what I'm on. I tried seeing if my touchbar changed when on slack/discord/youtube/netflix/hulu on both safari and chrome. I'm not sure if it's supposed to stay like this or I did something wrong during installation.

I also added a 4 finger gesture swipe for keyboard brightness. I don't know if that would've broken everything


It works with Itunes but notice how Show Finder is still around.


#1284

Ah, that's intentional! My preset doesn't change when you switch apps like Apple's UI does. I actually (at least personally) think that behavior is kind of annoying and prevents the development of muscle memory. I think having open apps add widgets to the home strip/menu bar is a better solution because it allows you to invoke various widgets and apps when you want to, and keeps the controls in familiar locations all the time. :slight_smile: so, to get to the browser tabs UI you can just tap the little Safari icon in the menu bar. It supports Chrome too!


#1285

Oh i missed that. Ok thanks for prompt response


#1286

Love the preset, but somehow 2.641 seems to cause this issue when it's active for me. :expressionless:


#1287

I'd like to inquire how to let "Fantastica" or "Calendar" alerts show up in my Touch Bar? I've set it to "visible", but nothing happens. I'm probably doing something wrong here...

(Latest version of BTT 2.697, latest stable version of Golden Chaos (2.641) with a 2018 15" MBP on MacOS 10.14.2)

also

BTW your preset + BTT literally turns a gimmick into something useful. Hallelujah! I'm so thankful for your work (and also to the dev who created BTT).


#1288

They should show up automatically as long as you've installed icalBuddy - if you haven't, I recommend installing it via Homebrew with brew install ical-buddy. Make sure you're using the GC-BTT settings menu on the Touch Bar and NOT messing with the checkboxes in the BTT preferences window.

Worth noting that the setting for which calendar app to use doesn't actually change where it gets the calendar info from - it uses icalBuddy either way, so the setting is just for which app should be opened when you tap on a calendar item.


#1289

Thanks. It works now! Just one more thing.
Is there any way I can configure all my upcoming events to say the day of the week as well ? It only says the date, time, and title. (Additionally, is there a way to make the text be in a different colour, depending on what kind of calendar it's on?)


#1290

icalBuddy is a pain, but it can definitely be modified to output all of those things. Check out icalBuddy's website where they detail how to write icalBuddy terminal commands to customize the output: https://hasseg.org/icalBuddy and https://hasseg.org/icalBuddy/man.html

You'll have to edit all of the calendar widgets directly through the BTT Preferences window to make this work, this is a deeper customization than what I offer through my settings panel. These changes won't survive between GC-BTT upgrades as a result, so consider copying the calendar widgets into your own separate preset so that they don't get deleted when you upgrade.


#1291

alright. Thanks a lot. I'll do my best to make it work (hopefully)


#1292

Just installed the new beta. Looks neat, really. The one thing that never worked properly for me is the switching of input languages --- if I activate that widget, I see "Hebrew (QWERTY)" and "Greek" (which I use for typing math & phys symbols), but "U.S." is never visible. (I suspect it's menu item number 0.)
I ended up installing this widget by @kovpas Current input source icon instead, which does the job fine.
What would also have been neat is, if I could edit what showed up in the Emoji picker (which in my case would be a bunch of mathematical operators like ÷∩βˆͺβˆβˆžβˆ†βˆ‡βˆŠβ‰ˆβ‰²β‰³β‰ β‰‘βŠ•βŠ— )


#1293

Hi!
Loving the GCBTT! just one small issue, I have no beats headphones and if I try to use the touchbar to connect to them through BT it doesn't work, even after renaming them Beats on BT menu. If I connect them manually, the beats logo changes to blue and all looks good, but cannot get them to connect just by clicking the touchbar. Probably I'm doing something wrong?


#1294

There are a few bugs with the language picker I intend to fix. Thanks for reporting this :slight_smile:

@Sergio_Martin If you tap the Connect to Beats button and then wait for ~10 seconds, do they eventually connect? Sometimes it's just slow because Bluetooth is slow, and trying again to connect just makes it seem like it went faster.


#1295

no luck, waited for a good while and nothing. not a big issue, as it takes 5 seconds to connect through the system settings


#1296

Does the BT menu open at all after you press the button? Do you see it click Connect on your Beats? If not, what do you see happen in the menu bar?


#1297

nothing happens, nothing opens


#1298

Do you have the Bluetooth menu enabled in the macOS menu bar?


#1299

@GoldenChaos

Non-W1 headphones don’t work right?


#1300

Any bluetooth headphones should work just fine, the script doesn't use any functionality from the W1 chip.


#1301

Interesting, I didn't know that! sounds cool.

Maybe after I get the AirPods UI setup working (i do need some help though) I'll change it to a bluetooth headphones button. So, It connects just based on the name right? And would the battery information work with any BT headphones?