GoldenChaos-BTT Support and Feedback Thread

feature-request
bug

#1262

Make sure when you import the preset you import all triggers and settings! Sounds like an import issue :slight_smile:

@ulrich1000:

  1. This is a super common question, I really need to add it to the first post in the release thread. There is an app-specific setting section in the BTT preferences window on the left side! There you can set apps to auto-disable BTT for.

  2. That specific message about the calendar widget does not apply here, but you are correct that if you want to restrict what calendars show then you'll need to edit the widget. It runs a one-line shell script that calls icalBuddy. You can check out icalBuddy's resources, they're pretty comprehensive, and include how to call a specific calendar: https://hasseg.org/icalBuddy/

  3. Reminders are also powered by icalBuddy, which lumps calendar tasks into reminders I believe. So if you have any tasks or todos in your calendar, my guess is that icalbuddy is sorting them as reminders.

@Andreas_Hegenberg question for you - is there a way to detect what Touch Bar group is open via AppleScript? I need to alter the functionality and highlighted state of menu bar buttons when entering and leaving their corresponding widget group.


#1263

Experimental GC-2.686 (latest to date)
15" MacBook Pro 2018

Issues:

-Main Issue-

  • Regarding the dynamic safari icon that appears when you open a browser, and you can click it for more browser options -- was working fine, with no problems, but now all of a sudden, when I have safari open, and I click the browser icon to open the browser group, it crashes my Touch Bar
  • the Touch Bar completely turns off, and my trackpad clicking feature turns off too. I can't make any clicks on the trackpad, but I can still move my mouse. I have to force-shut down my Mac, and then start it again, for Touch Bar / trackpad to work again.
  • I tried 2 times today, and both times upon clicking the safari dynamic icon, it has crashed forcing me to force-shut down my Mac.
  • I haven't changed any settings in the safari icon, I just moved it from the right side to the left side (because I'm left handed and preferred it this way) -- but I did this move days ago, and the icon was working completely fine until a few minutes ago now having activated it 2 times, both times has lead to a crash.

Please let me know if I need to provide you with any specifics for you to be better able to diagnose this issue, you can PM me if needed, I'll be happy to try to run any diagnostics on my end for you.

-Minor Issues-

  • The media keys / now-playing would flicker between paused and title-artist name when the media was paused, not as noticeable as previous releases, but still there
  • Media buttons + now playing used to disappear (when I first downloaded experimental 2.686 a few days ago) when I have no media player open, but randomly starting yesterday, the media buttons stay persistently and now playing just says "paused", even though I have no media player open

#1264

@urlich1000:

-Regarding Point 1-

As GC mentioned, there's a setting in BTT which allows you to disable BTT for specific apps in its settings, but I am currently using an alternative method:

  • Instead of disabling completely for specific apps, I have a global trackpad shortcut that allows me to toggle BTT on and off (simply assign your desired trackpad gesture to the keyboard sequence CMD+Opt+Shift+0) and that way I can use the nativeOS Touch Bar for apps I require, but also have the ability to switch back to BTT and use GC should I feel the need, rather than completely disabling BTT for specific apps and not having access to BTT at all for those apps.

If you feel you don't want BTT at all for a certain app, then disabling for that app is the better course of action, but I personally have found this to be a better alternative so I thought I'd share my $0.02


#1265

There's a new experimental version of GC-BTT out. Can you try installing that and let me know if you're still having the Safari crashing issue? Are you on the corresponding alpha version of BTT? What version of macOS? etc etc :stuck_out_tongue:


#1266

The only visual glitch I saw on the latest build is that the 12h/24h toggle does not change when clicking on it.


#1267
  1. Thank you! Exactly what I was searching (and did not find on my own). Actually instead of disabling completely I prefere "Touch Bar Behaviour/Shot App Default Touch Bar"
    2./3. I will dig into this, when I got more time.
    :+1:t2:

#1268

Device Info:

  • Device: MBP 15" 2018 TouchBar
  • Mac Version: 10.14.2
  • BTT Version: 2.689
  • GC Version: 2.686

I'm down to try the new experimental version of GC 2.689, but I had a question of updating. So I changed a lot of things in GC, adding new buttons, removing some buttons, and moving buttons around, as well as changing the colours of some buttons, and the clock's layout, etc.

My question is:

  • is it possible for me to update in a way that retains my changes?

  • Because I originally made all these changes in my previous GC version (stable), and I followed the steps of your GC thread, where I deleted my current GC from BTT, and then I installed new GC (2.686 which I'm using rn) and then in GC settings click reapply all settings, and this didn't return all the changes of my buttons I had previously made

  • I think I misinterpreted the update note, where it said my changes are retained in BTT even though I deleted my old GC to install the new GC, so I was under the impression my changes made to the code were retained somehow.

  • But now I think only changes made in the GC settings window are going to be retained, as all the code gets deleted for the new code of GC to be implemented right? Or will I have to copy all my new buttons, and just note down my layout changes, and then implement those changes manually in the new experimental version?

  • Just wondering if there's an easier way to do that, because I can't seem to make any changes or toggle anything in the GC settings window, and I find it easier to do it manually in the code you've written to change it to my liking.


#1269

There is no way to achieve that (and probably there won't be in the future as merging arbitrary custom changes with an updated preset is almost impossible).


#1270

I understand, thank you!

I figured as much, but I thought I'd ask anyway.

I'll stick to manually changing on my end.

@GoldenChaos I'll update to latest experimental version when I have some Time to manually make the changes and I'll report back to let you know if any of those bugs I mentioned earlier persist :slight_smile:


#1271

"Restore All Settings" can only restore changes made through the settings window, as you figured out, since it uses saved variables to store the settings. Custom changes have to be re-implemented, as you've discovered.

An easier way to avoid losing changes is to keep your non-settings-window customizations in a separate preset so they don't have to be deleted!


#1272

Hi, new here and I'm trying to setup this all up :slight_smile: Somehow, the settings for GoldenChaos-BTT are not updated? I tried the stable and the beta version: when I enable/disable a button (any) it won't update/toggle... Is there something I am doing wrong? Still very noob here :wink:


#1273

You need to completely remove any existing GC-BTT versions before you install a new one :slight_smile: the settings switches use unique IDs to update the widgets, which get changed on import if BTT finds that the unique ID is already taken. So if you haven't totally removed your existing GC-BTT, the settings switches will actually end up affecting whatever GC-BTT version you installed first.


#1274

Thanks for the reply. I did a clean install (in fact, hadn't used BTT in ages :wink: and stumbled upon your settings and gave BTT another try. So everything is clean installed, and I made the correct settings according to the start-post, but it seems that toggles simply aren't working. Or, sometimes they suddenly do but there seems to be huge lag or something: the keys/buttons on the touchbar will update: for instance: 24/12h toggle will not switch on the screen but wil switch on the touchbar).


#1275

Are you installing the experimental version? If so, there's a message in the release notes that says the settings switches don't update yet. The settings window is still in development :slight_smile: all the switches are hooked up but just don't update their appearances yet.


#1276

Nope, tried the stable BTT and presets first, then uninstalled and tried the beta's.

Will try again later today, with all first uninstalled, I'll let you know :wink:


#1277

@GoldenChaos excellent work my friend, the latest experimental version is working flawlessly, I'm not experiencing any issues that I mentioned previously in the exp. version prior to the latest.

Also can I just say, the caffeinate button is SUCH a brilliant and thoughtful idea! One of the many many reasons your preset is just a game changer for BTT. I couldn't be happier. Not to mention your excellent attention to detail to improve aesthetics whenever possible. I make a lot of modifications to suit my personal needs and I am just in awe of how much attention to detail you have for making the buttons look so aesthetically pleasing by paying close attention to which buttons should be attached which should be separated, etc.

Cheers my guy


#1278

That's great to hear that the latest version fixed your issues! :smile: and thank you for the very kind words. Cheers! :slight_smile:

In unrelated news! Slack has a new logo. And they've already updated all of their app icons everywhere! They even hacked into my computer and updated the Slack dock badge for me, that is some dedication to brand consistency. So I guess it's going out with the next experimental release.


#1279

I've been tinkering around with this. I'm unsure how it is supposed to work with Netflix/Hulu etc. 'Show Finder' is the only app shown no matter what I use.


#1280

Can you post a screenshot of your current Touch Bar?


#1281

Hey GC,

The newer versions of GC have implemented a feature where you show commands if none of these buttons are pressed, compared to showing commands if this particular button is pressed as you previously used.

I'm sure you have a reason for doing this, but my only concern with it is: I use Fn button as a key for hiding Touch Bar

This allows me to effectively use Fn key to display MacOS Touch Bar while keeping BTT as my main Touch Bar, and also using CMD / Ctrl / Option as other variations of the BTT.

But due to your new setting that "shows while none of these are pressed" vs. "this particular key is pressed" as it was before, now when I press Fn, instead of disabling and hiding BTT for as long as it is pressed, when I press Fn key, it basically shows all my CMD/Ctrl/Option/etc. commands altogether:

Is there any way to change it so that I can use Fn to hide BTT, which doesn't involve me going through all the commands and changing it manually from "show while none of these are pressed" to "show while this key is pressed" because I have a lot of settings, so I thought I'd ask if there's a better way to keep my Fn as a "disable BTT button" while it is pressed.

Device Info:

  • Device: MBP 15" 2018
  • Mac Version: 10.14.2
  • BTT: 2.696
  • GC: 2.689