GoldenChaos-BTT Support and Feedback Thread

feature-request
bug

#1181

Hello! How can i fix this problem? It happens when i close my mac, and opening it again after 1-2 hours.


#1182

Are you on the latest BTT version?


#1183

I am on version 2.665 (973).


#1184

@tibik, @Andreas_Hegenberg,


#1185

@Andreas_Hegenberg

Do you have any idea RE the issue I mentioned above that I was discussing with @GoldenChaos?

Seems like there's variables that should be available to the script but are "missing value". I'm happy to try and debug if you can point me in the right direction.


#1186

I don't know, are you running on Mojave? (The now playing API is not available on some older macOS versions)


#1187

@Andreas_Hegenberg

Yep, 10.14.1


#1188

@Andreas_Hegenberg

So, not sure if this helps... but I don't actually have the "now playing widget" visible. Just the media controls. Just now I toggled the "now playing" widget visible/invisible, and now the pause/play button is working as expected.

However, this has happened before when I've been fiddling, and at some point when I close/open my laptop or something, the script will return missing value again.

Are these properties only available when the "now playing" widget is visible?


#1189

Yes, they are only populated by the now playing widget!

In the current alpha you can also use a little hack in the now playing widget to get a simple play/pause button:


#1190

Oh man. Thanks.

This is almost perfect now! Only nit is the pause icon not aligning properly in the centre.

Thank you!!!!!


#1191

Yeah that's due to the hacky way I added it. This will be improved in one of the next versions.


#1192

First off. This is amazing and thank you so much for creating it.

  1. I'm having an issue getting Spark email notifications to show up. I clicked on the option within settings but have not been notified at all through the Touch Bar. The other programs like Messages work, but not Spark.

  2. is there a place that lays out plainly all the features, like a manual or tutorial?

Thanks again!


#1193

I'm having issues when it comes to the AirPods connect feature. The button doesn't appear to be doing anything. I read that the AirPods need to have "AirPods" in the bluetooth name and they are but still nothing.


#1194

how do i move my setup to a new mac? since backing up the preset and importing to the new mac causes the settings to not work.


#1195

You can always copy the complete ~/Library/Application Support/BetterTouchTool folder, but in general exporting should work. What exactly doesn't work for you?


#1196

exporting works but the settings menu inside GoldenChaos doesn't work after importing, as if i updated BTT without following Golden's instructions by first removing the preset then importing it again and "applying all settings".

Edit: seems i had a corrupt "backup" as i tried with an older one and it worked;However, i did downgrade to 2.645(954).


#1197

Just wanted to check in and see if you all had any thoughts or solutions for this.

Thanks!


#1198

Hey there! Sorry for the delay :slight_smile: to answer your questions:

  1. I use Spark as my primary email client, so I can confirm that they're working! The trouble is probably your Spark settings. You have to enable badges in Spark's preference, and you also need to make sure badges are enabled for Spark in your system notification settings. Check both of these spots and let me know if that solves your issue :slight_smile:

  2. An FAQ with solutions to common issues is on the way! Currently, the only documentation/tutorials are in the first post of the release thread, and are pretty much just installation and upgrade instructions.

@Andrew_Sfoglia AirPods can take a few seconds to connect, so please just wait a little bit after pressing the button. If it doesn't work, press it again and it will attempt to connect again - basically, all it does is press the "Connect" button in the Bluetooth menu bar for the first item with "AirPods" in the name.


#1199

Thanks for your response. It was the badges that were the issue. Appreciate the help!


#1200

Hi I'm new to BTT and this preset. I see that this preset should have buttons to thumbs up/down songs and heart them on Spotify but I'm not sure how to make those features actually show up on the Touch Bar. How would I get them to show up?