TouchBar Labels sometomes show incorrectly. (seen on large presets, maybe import issue)

touch-bar

#1

Describe the bug
Sometimes users who download presets get incorrectly formatted layouts.

Affected input device: TouchBar

Device information:

  • Type of Mac: Unknown, Customers Macs.
  • macOS version: Unknown, Customers Macs.
  • BetterTouchTool version: Unknown, Customers Macs. Likley 2.641+

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
I've not experienced this issue myself. From the screenshots that users provided, it seems like formatting has been incorrectly imported. The downloaded files are not corrupted when I download them.

Change parameters seem to be:
Icon Size
Background Color
Spacing (inside trigger)
Maybe spacing after button too.

Additionally, Gesture widgets seem to be converted to normal triggers, displayed in the touch bar as in Maneesh_K's screenshot.

@GoldenChaos, @Andreas_Hegenberg, @tergiversation, this relates to you.


GoldenChaos-BTT Support and Feedback Thread
#2

fwiw, this issue seems to happen more commonly on fresh BTT installations. Everyone reporting the issue seems to be a first-time user. Anecdotally, I went to an Apple Store and tried to install GC-BTT there and got this issue.

Perhaps it's related to BTT not having accessibility permissions? I wasn't able to enable those on the in-store MBP.


#3

I ran into this same issue when trying to install BTT and GC-BTT, both as fresh installs, on a MacOS Mojave machine. The issue appears to be related to some sort of import issue with presets. To finally get GC-BTT working, I had to download both the latest alpha and stable of GC-BTT, and import/delete them alternatively a couple of times via the BTT UI.

Not sure what the issue is, but if this affects multiple community presets, then I would guess that this is a BTT bug, rather than a GC-BTT bug.

BTW, thanks to all for working on BTT and GC-BTT!!


#4

I’ve had issues without presets, though this may be a separate problem:


#5

As far as I know this can happen when the Apple Script execution engine crashes or when BTT does not get the correct permissions to execute specific Apple Script functionality. Usually a BTT restart will solve it, but sometimes the issue is not within BTT's context, but in the system context. In this case a system restart may be required.

When running Mojave, make sure BTT has all the requested permissions in System Preferences => Security & Privacy => Automation.


#6

Aha! That makes sense. I'll make sure to note this when I write the FAQ since a lot of folks had been struggling with this one.