Connect to AirPods widget doesn't work if the Volume menu is disabled

fixed
bug
workaround-available

#1

I have some problems with the newest release of GC, if anyone else has/had these issues and found a fix I would appreciate some info.

My Airpods will show that they are connected, but the automatic bluetooth connect will not work upon pressing the button.

The following applications are not working as intended as well:

  1. Weather
  2. Spark
  3. Twitch
  4. Facebook

#2

The automatic bluetooth connection takes a few seconds. If it doesn't work the first time, just press it again and macOS will get the message. I use this feature daily so I'm certain it works :slight_smile: it just sometimes requires patience because bluetooth is slow to pair.

As for Spark/Twitch/Facebook - what's specifically, is wrong with them? I recently tested Facebook, and I use Spark as my primary email client, so I can confirm those two are working. The Twitch badge also just reads straight from the dock icon.

Finally - with weather, it looks like @Andreas_Hegenberg has hit the Dark Sky API limit again! When this happens you'll see the weather widget report 0 degrees and show a new moon symbol.

Hopefully this helped! Let me know about those dock badges :slight_smile:


#3

Wow a response from the legend himself, I'm honored. And I wanted to say thanks for all your hard work.

In regards to the AirPods: I can't find where I have to adjust the script to allow it to connect to my specific AirPods and I think that code got deleted with the update, if you have a link to how to do that.

For Spark: I don't know what's wrong, whenever I get email notifications, it's not arriving on my Touch Bar from the client.

For Twitch and Facebook, is the Touch Bar pulling from a specific app or online? If you could tell me the specific apps to use, maybe that's my issue.

Thank you for your response once again!


#4

The AirPods scripts, right now, is in two locations. In a future version I will merge them, I'm also planning on allowing you to customize your AirPods' name in the settings window. Keep an eye on the experimental versions! Until then, here are the two widget locations:


First one is in the menu bar.


Second one is in Connectivity Actions.

Inside the script, edit the highlighted bit to the name of your AirPods:

For Spark: Make sure you have dock badges turned on - they must be turned on separately inside the app's preferences (see below). Dock badge widgets do actually check the dock icon for a badge, which is how they work :slight_smile:

For Twitch and Facebook: Yup, as you guessed, they actually do check for a dock icon! For Facebook, I recommend making a web wrapper app with Fluid (http://fluidapp.com). It comes with built-in support for Facebook notification badges, too. For Twitch, they have a native app for Mac, so you can download that :slight_smile:

Hopefully that helps! Cheers :smile:


#5

You're amazing. Thank you!

I got everything to run besides the AirPods and the Facebook.

For AirPods, even after changing the name to the name of my AirPods in my bluetooth setting, it still won't allow me to connect when long pressing the button, though it will show me that it is indeed connected.

For Facebook, I did create a fluid app and the notifications are appearing on my OS dock, but not on my Touch Bar.


#6

Facebook actually I got to work, just the AirPods connectivity I can't seem to get to work after looking through how other people got it and following your directions.


#7

This is gonna sound silly, but... have you tried tapping on the AirPods widget instead of long-pressing? It's set to open the Connectivity Actions menu on long-press by default, which is why doing that wouldn't connect your AirPods. I don't expect it to be this simple but hey, I can dream :stuck_out_tongue:


#8

Yeah I tried that. Everything works except connecting. The script looks correct to me, but can't get it to work. :confused:


#9

I just had to change the name of "Temmie Flakes" to whatever my AirPods is called in my bluetooth settings, if I'm not mistaken?


#10

Yep, that's correct! When you tap on the connect AirPods icon, does the bluetooth menu briefly open in your menu bar?


#11

No it does not open.


#12

Hmm. Could you open System Preferences -> Security and Privacy -> Privacy and make sure that BetterTouchTool has all permissions it's asking for enabled?

If that's already the case, I am slightly lost haha. The script uses UI scripting to open the menu. If the menu doesn't open when you trigger the script, then only three things could be true as far as I know:

  1. The BT menu isn't there (doesn't sound like it)
  2. UI scripting is being blocked somehow (probably this)
  3. The script was modified in a way that broke how it opens the menu (this part of the script is pretty obvious though so this is unlikely, but couldn't hurt to reset the script to the default)

Optional fourth case is the button itself is not actually triggering the script. You can get around this by opening Script Editor.app (might come with Xcode, not sure if it comes bundled with macOS by default) and copying the AirPods script into a new document and running it from there to test.

You should see the script open the bluetooth menu itself and attempt to select an item. If it doesn't find an item, it closes the menu. If it does, it opens the item's submenu and clicks "connect". So you should actually be able to see it doing all of that!


#13

Yep all the permissions are there.

I reset the script and still no luck. When I run the script in the BTT menu it returns false.

I'm not educated enough on the matter to test your fourth solution, but thank you for trying.
I'll keep on the lookout for others with similar issues/resolutions or future iterations that may resolve this.

I truly enjoy and appreciate what your work has done to increase the productivity and value of my everyday life, so thanks again!


#14

Sorry to clarify, the script does run false when the AirPods are disconnected, but true when I manually connect them if that information helps clear anything up.


#15

Now my WhatsApp notifications aren't appearing as well even though they were previously.

:confused: Sorry for the bother. Just keeping you updated.


#16

You're not bothering! I'm incredibly sorry for taking so long to respond again.

This was also my bad - the AirPods widget has two scripts, one for displaying the blue/white icon and another when you tap on it to actually click "connect" for your AirPods. That second script is the one we need to test!

It's located here:

When you manually run the script, does the Bluetooth menu open?

As for WhatsApp, make sure the app is running, otherwise badges won't appear. The WhatsApp desktop app is particularly finicky with the whole "staying running" thing.


#17

Yup that fixed WA. Will check on the AirPods


#18

When I manually run the script the Result: ""


#19

Did you see the bluetooth menu open at all? Are you 100% sure you have the bluetooth menu enabled?


#20

Yeah the bluetooth is enabled in the menubar, and I can manually open it. I'm sure about that. I'm starting to think it's some weird interaction with another program I have, possibly BarTender. I'll test a couple things if you don't have any ideas.