Connect to AirPods widget doesn't work if the Volume menu is disabled

fixed
bug
workaround-available

#21

If you've hidden the bluetooth menu in the bartender bar, that would prevent it from working. Make sure that you don't have it hidden inside bartender!


#22

I just unhid it and no luck :confused:


#23

Could I see a screenshot of your menu bar? And the bluetooth menu contents, too, if you don't mind :slight_smile:


#24


#25


#26

There you go


#27

Geez... you got me on this one. Everything you've showed me now looks like it should work. I'm stumped.

@Andreas_Hegenberg can you think of any reason why the Connect to AirPods scripts in my preset would be unable to open the BT menu bar item? I'm a bit at a loss with this one.

If I think of anything in the meantime, I will update this thread for sure. I'm sorry I haven't been able to solve this... but for sure it's going to be keeping me up at night, haha.


#28

If this helps


#29

That script doesn't open the bluetooth menu, so it's not related to your issue. In fact, since you said the icon turns blue, that means that particular script is working properly :slight_smile:

When you said you were running it manually, which script were you running? You should be running the one I mentioned in my post above. The one you posted a screenshot of is not the correct script. Please make sure you were testing the correct script! It could actually be working, haha.


#30

Yeah I tested both just in case. Here's the other one.


#31

That's the same script - the AirPods button has two scripts inside of it, please see my tutorial above for how to locate the second script that handles the connection.

However, a better way of testing this now that your setup is correct would just be to tap the AirPods icon on the Touch Bar now.


#32

Then there's an error in my download, because I posted the first one from the connectivity script above calendars.


#33

There's no error for sure, you're just not clicking the right place. Make sure you're clicking the gear in the red box. You will be taken to a different looking window with the second script. See below!


#34

Ok I got it, but when I click run script now, the result remains blank.


#35

You should see the bluetooth menu open when you run that script. Does this happen?


#36

Nope, nothing opens. I've never gotten the bluetooth menu to open besides manually pulling it up from settings.


#37

I'm talking about this menu specifically:

54%20PM

NOT the System Preferences bluetooth window.

I think you have everything working properly, we're just having trouble communicating now. You should be able to use the AirPods widget. Just try tapping it on the Touch Bar as normal now, and the bluetooth menu should open and try to connect to your AirPods. No need to manually run anything anymore.


#38

By "manually" I meant, hit that Open Bluetooth Preferences button. But the script nor pressing on the AirPods button opens that menu up.


#39

Share a screenshot of the script you're running again? Just to be 100% sure you're running the correct one this time, haha.

Thank you for being so patient and testing this with me!


#40

No worries, and thank you.