BTT loses custom snap areas over time requiring app restart to restore

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.
Over time, BTT forgets about custom defined snap zones (they no longer appear). Restarting the app restores these custom snap zones.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard/Mouse

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro
  • macOS version: 11.6.3
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    BetterTouchTool 3.741

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Restarting the software resolves the issue

Same here. Ever since I got my new MBP 14". Didn't happen on my MBP 2016 on Big Sur. So not sure if it's Monterey or the new Mac. But @JoshW is on Big Sur, so must be the new Mac.

upgraded to Monterey - this is still an issue.

You can 100% demonstrate this issue by simply putting your Mac to sleep. After wakeup, all custom snap areas are gone until you restart BTT.

unfortunately I have never been able to reproduce this (sleeping the mac doesn’t loose any snap areas for me). Is your display directly connected to the Mac? Or though some sort of hub?

I have two displays. My 27" Dell S2721QS is directly connected to the HDMI port on my MacBook Pro 14". My 19" NEC LCD1970V is connected VGA to the Satechi USB-C On-the-Go Multiport Adapter (USB-C On-the-Go Multiport Adapter | 9-in-1 USB Type-C Hub).

When I wake from sleep (typically in the morning or after a longer time period it seems) snap areas do not display until I either restart BTT from the menu option or quit and relaunch BTT entirely.

Keyboard Maestro users can use this "hack". :smiley:
Set it up today, I'll see if this helps the situation (at least for now).

1 Like

Mac -> USB-C -> Caldigit Hub -> HDMI -> External Monitor

you could also enable the restart after sleep option in the advanced btt settings

1 Like

Didn’t know about that. I’ll give that a try!

Hi I have this issue and have reported it to @Andreas_Hegenberg by email a few times. I use BetterSnapTool 1.9.5.

Quitting and restarting BST doesn't work. I have to restart my Mac to get it to work again. It started around the Monterey update (OS v.12.2.1)

A few other potentially relevant/related threads I came across while searching just now:

FYI - for me, ever since I enabled the "Restart BTT after wake from sleep", I have had no issues.