App Specific TouchBar 'Show Default App Bar' issue with macOS Control Strip


#1

Describe the bug
@Andreas_Hegenberg, I'm seeing an issue where when an app's 'Touch Bar Behaviour' is set to 'Show Default App Bar', the control strip sometimes remains when the BTT bar is opened even if 'Show macOS Control Strip' setting in General TouchBar Settings is unchecked. Could you take a look?

03%20pm

You can see here, my layout is designed so that the control strip and system X on the left should be hidden and replaced by my replica within BTT, however the system buttons show up anyway so the view get's jumbled.

I suggest implementing two options instead of the one:
Show Default App Bar, Hide macOS Control Strip
Show Default App Bar, Show macOS Control Strip

Affected input device: TouchBar

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • macOS version: 10.13.6
  • BetterTouchTool version: 2.641

⎢UPD: 19 Dec 2018⎥ AquaTouch: Supports 35+ apps and websites, AND the native TouchBar. No Compromises!
⎢UPD: 19 Dec 2018⎥ AquaTouch: Supports 35+ apps and websites, AND the native TouchBar. No Compromises!
⎢UPD: 19 Dec 2018⎥ AquaTouch: Supports 35+ apps and websites, AND the native TouchBar. No Compromises!
BTT 2.66x discussion - Problems with new features
#2

Bump:: No activity..


#3

@Andreas_Hegenberg, Any help here?


#4

Sorry I haven't been able to reproduce this at all and have never seen such behavior.
Maybe you have an app-specific override somewhere that shows the control strip?


#5

It’s set to show default app bar.

There might be a conflict here and i’m suggesting adding:

Show default app bar, hide control strip when opened
Show default app bar, show control strip when opened.

This has been reproduced on other systems as i’ve seen a bug screenshot from @Dom with the same issue.

To clarify, the issue is:
CS occasionally shows when App-specific behaviour is set to “Show App Default touch bar” and the group is opened, even though show macOS CS is disabled in BTT.

AppSpecifi: Show App Default Touch Bar
General TB Settings: Show MacOS CS [OFF]


#6

Ah now I understand!
This is currently expected behavior, but I think adding the options you suggested is a good idea!


⎢UPD: 19 Dec 2018⎥ AquaTouch: Supports 35+ apps and websites, AND the native TouchBar. No Compromises!
#7

@Andreas_Hegenberg, Little reminder here.. How’s it going?


#8

@Andreas_Hegenberg,
Just had another instance of the issue.

Additionally, I’ve notice that often this happens if BTT is accessed through the macOS now playing touch bar, as it also happens randomly.

I’d really appreciate a fix! It’s one of the very inconvenient bugs for my AQT preset which is growing in popularity


#9

It will be in the next version which will be released by the end of next week!


⎢UPD: 19 Dec 2018⎥ AquaTouch: Supports 35+ apps and websites, AND the native TouchBar. No Compromises!
#10

Thanks for the fix! _


New BetterTouchTool UI Progress
#11

Would be great if you'd try alpha v2.661 (please expect bugs as I have change MANY things in preparation for the new UI)

This was a bit complicated, let's see whether this works correctly:


#12

Notice for Everyone using AquaTouch v3

@Andreas_Hegenberg has rolled out some much awaited BTT features that i've been longing to implement into AQT.
These features will add further quality improvements and bug fixes, but will require you to update using BTT's Alpha release stream.
BTT's alpha versions are still in testing phase so it may be buggy. AQTv3 is also in testing phase too, so I guess we could all come together to help Andreas solve any bugs with the new features. More people = more tests!

AQTv3 will only be released when these new BTT features are released in it's stable release.

Thanks again!

EDIT: I can't seem to update to the alpha. It's returning an "Update Error!" window