After sleep, global touchbar widgets are not visible


#81

Weird, is the "always run on becoming visible" option checked for these widgets"?
What is their refresh rate?
Possibly some other script is blocking and prevents the scripts from running (as only one Apple Script can be run at the same time)


#82

Always Run is on for some of them and refresh rates range from 2 seconds to 2 hours. Some have the same refresh rate. Maybe they're trying to run at the same time?


#83

They would just be queued in that case.

I'll add a debug mode which will be able to show which script blocks execution (if any) with the next alpha .


#84

With 2.650, it's back to not showing up without toggling on/off


#85

Yes. I have to launch BTT and click Restart BTT for it to show.


#86

Was working better on 2.649/2.650 but just unlocked my laptop after leaving it alone for a day and a half and my BTT touchbar was not showing. After pressing the toggle shortcut a few times it did eventually come up though if that is helpful. Before that hadn’t had any problems with shorter sleep periods though.


#87

@Andreas_Hegenberg in my case 2.650 seems to be working fine - perhaps because I did those steps before update. I didn't re-do them, but I haven't experienced this bug in a while due to those fixes. It seems to be fixed for me, even without clicking any checkboxes etc.

Perhaps you just should just try to reinstall BTT and import last config to see if it works for you as well?


#88

Having still found no common issue to the BTT Touch Bar issues, I have also deleted BTT and all prefs and reinstalled. I will report back my findings after a day or so of normal use. So far, two times coming back, it is working.

One word of caution!
I exported my settings and imported them after the new install. Any of the "run apple script" actions that have a script in the Advanced Config setting lost the scripts from that area! If there was only or also a script in the Predefined Action, it was preserved.


#89

That is very weird. Which version of BTT are you running?


#90

I have this problem multiple times every day. It is very annoying.


#91

6.245 - Both the version I removed as well as the version I downloaded to re-install.

For what it's worth, the problem is still intermittent.


#92

Still having this problem as well, even on the latest alpha build (2.651). Most times now it seems that I can get BTT to reappear after pressing the keyboard combination a few times, but it still intermittently doesn't show after waking up from sleep.


#93

still consistently happening for me, almost every time the Mac is asleep for more than a few minutes.


#94

This actually happens every time it wakes up from sleep, and I have to restart BTT every time it wakes up from sleep. Really hope this gets fixed ASAP. (I am using 2.652 (962) alpha version.)


#95

Can anyone who still experiences this issue can confirm that this: After sleep, global touchbar widgets are not visible did not solve the problem? I've tried it on two Macs already and it does work since that day. Perhaps a reinstall + few little steps is all you need to have it up and running


#96

Yeah, I tried these steps with several of the last few alpha versions and I'm still having this issue. Seems that now at least BTT is still running in the background on wake though since I can get it to show up again by toggling it on/off with the shortcut. I think BTT thinks that it is showing since I need to toggle twice to get it to reappear (i.e. toggle off and then back on again).


#97

I too noticed that I have to toggle twice. Hadn't given it much thought... assumed it was me not hitting the key combo correctly :roll_eyes:


#98

Just want to add on that I am also getting this annoying issue.

I am using Global Chaos presets, and on my new MBP 13", 16gb ram, i7 on Mojave 10.14.


#99

also still having this issue nonstop.

my trial is running out, and I definitely want to purchase, but this feels like a bit of a showstopper.


#100

Describe the bug

I too am having issues like this, with some additional problems. I had a fresh install of BTT Trial Version yesterday and loved it. After sending the machine to sleep I awoke it to find BTT malfunctioning.

First of all I noticed that touching the Now Playing Widget no longer paused or played Spotify, it opened iTunes instead. I had a look and the default in BTT was indeed set as Spotify. I rebooted.

Now, I have a wired mouse and at the login screen the cursor direction was inverted. Moving the mouse left moved the cursor right. I used the trackpad without issue to click and log in.

Once logged in the BTT widgets had all disappeared apart from a small grey square. Clicking that opened iTunes so it seems to be the Now Playing Widget, but gutted.

I uninstalled, fully, and rebooted. Cursor issues went away. Reinstalled and re-setup my configuration. After sending it to sleep the same problems recurred.

I updated to the current alpha version and closed/reopened BTT but no luck.

I have just had a look at the Now Playing Widget and see it has reset itself to iTunes as the default app (maybe as a result of upgrading to the alpha?). I have set it back to Spotify. I then looked at App Switcher and see that it has set its own width to 0px. I reset to 250. Date/Time has also wiped my setup so I have re-typed 'E d, hh:mm'.

I sent the machine to sleep, briefly, woke it and everything seems normal. I rebooted and at login I still have inverted cursor issues. After login the mouse performs as it should.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Touch Bar, and wired mouse at login screen

Device information:

MacBook Pro 13" 2017
macOS 10.14
BetterTouchTool 2.652