After sleep, global touchbar widgets are not visible


#61

thank you all, I have now received enough samples and will work through them today!. Let's hope I can finally reproduce the issue :slight_smile:


#62

HI Andreas,

Is there any progress on this matter?
Thanks in advance for the info!

Regards,
Christiaan


#63

Unfortunately even after trying all the samples I received on my system I was unable to reproduce it :frowning:
In all of the logs, the system seems to think the Touch Bar is showing fine...

I have made some more changes to speed up the start up process, in case it is a timing issue. I have also fixed a bug that could appear with some system languages.
It would be great if you 'd try v2.647 alpha.

If that also doesn't help it would be great if the fix described by @Worie (After sleep, global touchbar widgets are not visible ) also fix the issue on your systems.


#64

Just FYI @Andreas_Hegenberg - I don't think it is a timing issue - sometimes BTT strip takes control over touchbar even before loggin in (i mean, few versions ago the BTT initialized after login, now sometimes it does override the TB even before it)

I'll try the new alpha later today and let you know if it fixed anything


#65

And I think sometimes BTT is causing the the login screen to hang at times.


#66

Timing seems logical to me. I have been trying to keep everything the same (always close the lid when I'm done using the computer, the only thing plugged in is the charging cable) and so far I am seeing mixed results. I will start keeping a log of info to include approx how long in sleep and anything else I can think of.

The good news is that I can correct it every time by clicking the BTT icon on the toolbar and restarting BTT.

13" 2018 MBP


#67

Thanks for the hard work. Unfortunately, v2.647 alpha is not solving it for me.


#68

v2.647 alpha not solving it for me either


#69

Ignore my last... 5 times since my post and I have closed the lid only to come back and find that the Touch Bar has reverted and requires a restart of BTT.
First 4x, with only the charging cable plugged in
Overnight, nothing plugged in. Battery power.

  • Is it possible that one of the buttons/widgets we are running on the tool bar is causing the problem?

#70

Unfortunately v2.647 alpha hasn't made any difference for me either.


#71

One more question:
Do you really need to restart BTT to get the Touch Bar to show up again when this happens? Or is it enough to use the predefined action "Toggle BetterTouchTool Touch Bar" (e.g. assigned to a keyboard shortcut).


#72

Yes. I always have to quit BTT and then start it up again so that I get TouchBar to work again. Really annoying. :disappointed:


#73

Did you try the toggle method using a keyboard shortcut?


#74

I'm trying something new in v2.648 alpha - BTT is now restarting after leaving the login screen and ignores the macOS notifications about wake/sleep. Maybe these notifications are buggy on Mojave.


#75

I'm trying to quantify a theory as well... most of yesterday I was having no issues when coming back to my MBP. I realized that I wasn't immediately "doing" something (keyboard or trackpad input). While this was only a couple seconds, it seemed to make a difference. This morning, I opened the MBP and immediately swiped the trackpad, the Touch Bar was not showing my BTT global and BTT had to be restarted.

I am mapping the Toggle function to a keyboard shortcut now to see if that helps, but I haven't been manually quitting either - I use the restart option from the menu bar icon.


#76

Tried v2.648. Computer got updated during the night, and when I woke it this morning (before even logging in) BTT was flashing on the Touch Bar. As in, it was constantly cycling between BTT and the native touch bar.
After logging in, BTT was showing, but scripts weren't running.
If I open a widget and press Run Script, it works and shows the result, but the Touch Bar isn't updating. It just shows the titles and icons of each widget. Reseting BTT doesn't fix it.
Restarted the computer (tried sulmen's suggestion of not touching anything while waiting), BTT showed up but scripts didn't run, then it was not responding. Restarted BTT and it finally all started working.


#77

Oh even if that behavior wasn't intended, this is very interesting. This sounds like it is indeed related to an issue with the Mojave login screen.

I have made one more change in v2.649 which should prevent the restart-cycle.


#78

Touch Bar showed up immediately after sleep this time (yay!) but it took about 5mins before the widgets updated. Slightly irritating, and it means it was faster when I had to toggle BTT on/off after waking.


#79

what kind of widgets?


#80

All the my applescript ones - NowPlaying, calendar, messages/mail, PIA. They show up first as their title and icon, but don't run and show results for a while. The only things that show up right straight away are buttons, date/time & weather.
Looks like this: