"You have not yet configured actions to BetterTouchTool."

Hello. I am using a Macbook Pro 2019 15" with the most current updates of both Mojave MacOSX and the BetterTouchTool software. I tried out BetterTouchTool before purchasing the subscription, and since doing so have encountered a very aggravating issue.

Before, I was able to show the custom BTT touch bar by pressing the Control button. Now, I have to be holding that button to display my widgets.

I messed around with the settings and tried disabling both the "Hide global actions if app specific actions are configured in BTT" and "Hide BetterTouchTool Touch Bar if nothing to show (no actions configured)," but the issue persisted. Now, when I press my modifier key (Control), it displays the message "You have not yet configured actions to BetterTouchTool."

I would really appreciate a speedy response! Thank you.

How did you configure BTT to show your Touch Bar when pressing ctrl? I think the only way to achieve that would be by creating a custom key sequence, record the CTRL key and assign the "Toggle BetterTouchTool Touch Bar" action.

I adjusted the Modifier Keys for the widgets that I want to show up in my Touch Bar.

But in that case they will just be shown while holding the modifier keys. As far as I understood this is not what you want?

I thought that the Modifier Keys toggled the visibility of the touch bar like it used to do, but I may have just been relying on a bug or something. Is there another way to do the thing that I want to do?

you can either setup a keyboard shortcut and assign "toggle BetterTouchTool Touchbar" or a key sequence where you assign that actions. Key sequences can also consist of single modifier keys, so that would probably be necessary to recreate the same behavior.

I tried that with the shortcut CTRL+T, but the problem persisted. The BTT Touch Bar only showed up while the keys were held down, which is the thing I don't want.

Do you still have the modifier keys assigned to the buttons? (This will cause them to only show while the modifiers are pressed)

Yes, but that is because when I activated the option for them to always show regardless of modifier keys, they still wouldn't show up. Setting them to work when I pressed Control was the only way I could manage to get them to show up on my Touch Bar.

I'd try to remove that. Probably your Touch Bar was previously hidden and assigning modifier keys will temporarily unhide it if they are pressed, thus they only showed in that scenario.

You can now toggle the hidden state using the "Toggle BetterTouchTool Touch Bar" predefined action.

Yes! That's exactly what the problem was! It was hidden and the only way to get the Touch Bar to show up was pressing my modifier key, but the only way it'd stay shown is when it'd be held down. I'll try your solution right now.

Alright, now I'm at a point that I was at before where I thought the problem was solved but another problem arose. Now, the BTT Touch Bar shows up when I press Control (my desired key), but it also shows up when I press Caps Lock, Shift, and Command, even though I also set up the predefined action keyboard shortcut.

I think something is messed up with your setup :smiley:

Maybe export your preset and post it here or email it to me, then I'll have a look.

Alright, here you go!

dobotime.bttpreset (66.2 KB)

Any progress?

Coworker of mine, who is a GC-BTT user on the latest alpha, just had this happen without him intentionally disabling the BTT Touch Bar. Clicking the notice "Your BTT Touch Bar is currently hidden, click here to enable" does not work, and launches the legacy config UI instead.

The solution is to click the BTT menu bar icon and then go to "Enable BTT for...", then enable BTT for all apps as shown:

I didn't even know that menu option was there, so go figure.

Seems like there may have been a bug recently that flipped this switch off for some users?

Interesting, I have just added a more suitable warning for this case:
image

There was a problem with a version a while ago, where the disabled state was ignored. As far as I know affected users disabled BTT manually at some point (maybe accidentally), but it only became relevant after a recent update because previously the disabled state was ignored due to the bug.

I think it would be even more intuitive to also move the whole “Enable/Disablt BTT for...” item upwards into the same section as the warning. It’s just not easy to notice down at the bottom there. But if it were directly under the warning I think people would find it.

I think the main issue is that people didn't realize BTT was disabled, with that warning they at least know about that and will probably be able to find a way to enable it again :slight_smile:
I currently don't want to change the menu too much as there is still various old legacy logic in there that i have probably long forgotten about and which may depend on the location of some of the items :crazy_face:. That's a task for some other week to refactor.

1 Like

Any updates on my presets? I'm still faced with a lot of the same issues and havent been able to find any solutions on my own. Thanks!

Imprint | Privacy Policy