Window snapping isn't working

Describe the bug
Window snapping isn't working. BTT does have accessibility and screen recording permissions.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MBP 14-inch 2021 w/ M1 Pro chip
  • macOS version: 12.0.1
  • BetterTouchTool version: 3.611 (1759)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

have you tried to restart your machine? I haven’t had any window snapping related bug reports recently , so I assume it’s something specific to your setup :-/

Are you sure window snapping is enabled in the BTT settings?

Yea, I also updated my macOS thinking that could be a factor but wasn't.

And yes, it's enabled.

Are there other ways I can help you debug it? I'm a software engineer too so it's ok if the way is technical.

Doesn't it do anything when dragging a window to the edges? So no preview animation, nothing?


After the Monterey upgrade, this has been happening to me as well.

Window snapping and any Window Resizing keyboard shortcuts defined in BTT no longer work. These are shortcuts I've used habitually for many many years now.

Restarting BTT doesn't seem to help.

Restarting my Mac sometimes fixes it but not usually.

BTT does have accessibility and screen recording permissions.

1 Like

Most likely it's some sort of permission issue as it seems to work like before on most systems. I have had (very rare) cases of corrupted tcc databases with previous macOS upgrades, maybe that's again something like this.

You could try to reset the accessibility permissions via this terminal command (save any unsaved work before running this, sometimes this causes a restart):

sudo tccutil reset Accessibility

That + restart fixed it. Thanks!

That + restart fixed it here as well!

Thank you so much for the quick response and resolution!

Update: After another restart, window snapping stopped working again.
Running "sudo tccutil reset Accessibility" caused a complete OS hang this time.
But after force restart (and granting permissions to all of my apps again) it's all working properly again.

That hang is a bug I have reported to Apple multiple major macOS versions back. I assume this will never be fixed. BTT can recover from that after a few seconds, but most other apps listed under accessibility can not...

This whole TCC / Permission stuff seems to break with every major macOS version for some users :frowning:. If it happens again I can describe how to completely reset that database, but this is complicated and involves booting into recovery mode :-/

Thanks for the quick response.

That hang makes sense. After running the tccutil reset command I did invoke my app switcher (witch) which requires accessibility permissions as well. I'll bet the hang was the result of that.

If I reset the database, can I re-import all of my BTT settings or would I need to start from scratch?

FWIW - Monterey seems to have caused more than just BTT to act funny. Other apps that require accessibility permissions seem to lose them after a restart (even though it visibly shows that they have them.) It seems that only after resetting per your instructions do these apps work properly too.

It's not a BTT database that's affected, so your BTT settings would stay as they are.

It's this system database that's causing problems after upgrades: ~/Library/Application Support/ (that contains all the accessibility and other permissions). This database is very hard to reset completely because it's protected by the highest protection mechanisms macOS offers :slight_smile: The tccutil command somtimes works, but it can not do a full reset...

Also, having the same problem. Custom snapping works fine but not the default. The solution didn't work for me either. Just made the whole system hang until I did a force restart.

If snap areas work your issue is not caused by the database issue.

Maybe snapping is just disabled?

No they are definately enabled. I was thinking it might be an issue with spaces.

So every time I restart (or turn on), things work (able to snap). But when I log in after MacBook pro-2017 goes to sleep due to inactivity, it does not work. I've only recently experienced this with my MacBook ever since I've upgraded to macOS Monterey. Are there any tips other than what's already mentioned in this thread?

CORRECTION: After wrestling that problem and doing all the steps I found out a little dark grey button on top right-hand corner of the BetterTouchTool window saying something along the lines of "Attention! BetterTouchTool is disabled!" or something and clicking that button made it go away and also Window Snapping works again (both default and custom ones) :+1:

I have this problem for quite some months after years of happy camper. That sudo command didn't work and neither did restarting my Mac. I've re-added permissions for BetterTouchTools for Accessibility and Screen Recording. I have Window Snapping enabled. I'm running M1 MacBook Air with macOS 12.2.1 and BetterTouchTools 3.741. I've paid for BetterTouchTools directly but since subscribing to Setapp now I am running BetterTouchTools via Setapp install (if it makes difference).

1 Like

/u/heikkipekka Thanks for this tip - I was in the same boat. October 2022, running macOS Monterey 12.5.1 on a MacBook Pro (14 inch M1).

I have had the same problem since I updated to 3.888 version : windows snapping, but also windows moving&resizing do not work in this version on my machine. It behaves just as if these functions were just not enabled.

I have tried rebooting, but also disabling and re-enabling them in "Basic" and "Windows Snapping & Moving" tabs of the global settings, without success.

Rolling back to 3.826 version immediately solved the problem, however.

Let me know if you want me to do some more testing!