[v3.6.5] AquaTouch -- Powerful, Flexible, Contextual. Supports 55+ Apps and Websites.

@yuuiko I am sorry to say that I do not use your preset as I find it too complicated.
BUT I am really hoping you can help me with something.
I have been asking everywhere for help with this:
Do you have some code I can use that does the following:
When I tap on a button labelled "Add to Playlist", it opens my Spotify playlists.
I will then tap on the desired playlist and it will add the currently playing song to the playlist I tap.

I am really bad at coding unfortunately, so please talk to me really REALLY descriptively.

Thanks so much :slight_smile:

1 Like

Who likes this new QuickMedia back button?

I find it quite nice, I can just double tap that spot to close out to the app controls as the QuickPlay close button is in the same spot now.







And does anyone want a discord?

  • Yes Make a Discord!
  • Just passing by....

0 voters

1 Like

The "star rating" script for the Apple Music app doesn't seem to load in my Touch Bar it shows up for about 1 second and then enter goes away? is this a glitch in the OS? I'm currently on Catalina 10.15.4

@Duval_Barrett

You might need to enable it by holding option. The QuickStrip should change to "music settings" and there you can change it

i should document this...

1 Like

@yuuiko thought you'd want to know.. I dunno if this is a bug only for me but all of the apple icons from the pack you have turned all stretched:


not just for aqt but for my personal touchbar too.
thanks

Looked like the YouTube widget is not working for me (see screenshot)

Yes I have the setting enabled

Thanks!

@Future_Face

Somewhere in BTT TouchBar Settings there should be an option that'll keep icon proportions. Try find that and check it

@Michael_Rodgers
Seems like a common issue.

Try see FAQ: Stuck Youtube Setup and Fix

1 Like

Ok thanks.
Also, doesn't Aquatouch have a media scrubber for Spotify in it? If so, can you please either reply to this with the code for it, or tell me where to find it in AQT?
Thanks :slight_smile:

Having a issue at the moment which I think is linked to Apple Script but the Apple music add to libary button keeps going missing. Any ideas?

thank you

1 Like

Hello, new user here! :slight_smile: Firstly, love the BTT preset. However I am having an issue with the Game Mode function. It shows all the icons, but it doesn't show the values for the CPU temp, etc next to the icons in the touch bar. I did some extensive searching around the forums & elsewhere, installed homebrew, to no avail. Does anyone have a step by step process on how to see the actual values next to the icons? Game Mode was a HUGE selling point for me & I hope I can get it to work soon! Thanks in advance to anyone with some info!

@Benjamin_Leo_Challin
Might be outdated code, I don't have apple music so this may be the case.

@Userwastaken
Welcome and glad you're enjoying it!

GameMode has some install difficulty due to changes in Catalina. I've seen some users being able to install it but limited success. The why I got mine working was the equivalent of tearing down a wall to open a door.

This solution looks most promising to me though It's not exactly step by step...

Thanks for the speedy response!

So I've actually seen that post & tried to follow it to the best of my ability, but I'm still having issues. Firstly when I use the install iStats function in the preset, the terminal says I don't have write permissions, so I went & manually changed that so I could read & write. Now when I try the button in the preset it shows a ton of tracing data & basically says "Permission denied @ rb_sysopen - /Library/Ruby/Gems/2.6.0/cache/sparkr-0.4.1.gem (Errno::EACCES)" & gives me an "While executing gem..." error. Any idea where to go from here? I'm not very fluent with commands/terminal stuff but seems to have something to do with the file directory maybe?

EDIT: Forgot to mention the exact permission denied thing ALSO shows up for iStats & parseconfis-1.0.8.gem.

To get those working basically all you need to worry about is getting the "istats" command working in terminal. AQT uses that command internally and essentially is just a mini terminal display. Once you can get this working, AQT should either connect in a breeze or even automatically.

I'm actually not versed in terminal either ahah, before catalina it was very easy. I only got mine working with pure, and i actually mean pure chance, I don't even know where iStats is installed.

So, iStats is a "gem" coms from a place that's called "ruby".
It seems MacOS uses some gems and code from ruby itself, but in the last catalina update, apple seems to have locked that installation down "because security".

A big help was this article, Have you seen it / tried it?

From it I now understand that we'd need to start our own directory and ruby gem install system instead of just installing to apple's internal OS directory as pre-catalina...

I'm quite busy so maybe have a look at that site and see if you can get something. If not I'll try look into it further, though I'm afraid that my ruby installation would look, if it was in the physical form, like a hacked together patchy mess!

YES! I figured it out. Not sure how I didn't figure this out sooner, but I hadn't seen the terminal stats like that before so I did some searching & all i had to do was type "sudo gem install iStats" & enter my password, then I immediately tried the buttons in the preset again to show the CPU temp etc & it worked immediately. So I think to anyone else having issues, they just need to type that sudo command above & it should work properly if everything else was installed correctly. No need to change any permissions of folders or edit the preset scripts! :smiley:

EDIT: I guess I just didn't have or know how to properly install the iStats gem & where to put the .gem file, but now it appears in the /cache folder where I assumed it would go.

EDIT 2: Now that I have this figured out, how do it make it so Game Mode automatically turns on with a certain game app? For example Minecraft. I looked at another thread where you had screenshots of changing the conditions under GameMode & QuickStrip, but I wasn't sure where to actually put the condition & what parameters to enter. Sorta want it to just appear like the Gesture Bar does but with ONLY Minecraft, of course. :slight_smile:

hi /u/Userwastaken
actually I did on purpose avoid using sudo gem install iStats to avoid messing up with the MacOS Ruby. That's why in the other threat I installed another ruby folder using the homebrew (brew.sh).
But in the end good that it worked for you

I guess you can find the menu Yuuiko is showing to add the game automatically
here is where the menu is. (that's for the gamemode menu - the first step. second step is similar but in the other section - see in the other thread to do the exclusion)

Ah that makes sense.

I've seen where the edit conditions button is, but what do you change once you click on that? It seems like I could easily mess the preset up by doing it wrong so I wanna make sure that I put the right parameters in the right fields & such.

@Userwastaken

@yuuiko bump

Any plans to fix this? Do I need to enable scripts anywhere maybe?

Imprint | Privacy Policy