Update to version 3.178 using old configuration instead of new configuration

Hi, using 15" MBP, OS 10.14.5.

BTT 3.148 was going well. I had configured custom touch bar for an app (Jump Desktop).

I upgraded to BTT 3.172, but found that the touch bar wasn't activating on app switching to Jump Desktop (there's a separate bug report thread on this), so moved back to BTT 3.148.

I configured BTT 3.148 with more touch bar changes. Now, I've tried updating to BTT 3.178, but find that the touch bar settings are stuck at an old configuration. Specifically, they are stuck at there they were at the time I trialled BTT 3.172. All the new changes I made in my time back in BTT 3.148 are lost.

I have replaced BTT with the 3.148 version again & all my touch bar settings have returned to my latest version.

How do I get BTT 3.178 to recognise the changes I have made to the settings in BTT 3.148?

switching between older and newer versions is unfortunately not supported, only if the update path is continuous.
You can download 3.148 via https://folivora.ai/releases and then export the settings made in that version using the Presets => Export functionality. This can then be imported in the newer versions.

Thank you. I will try that.

The intention wasn't to shift back to the previous version but rather to deal with the bug reported here (Touch Bar keys keeps hiding everytime I switch between apps.). This seems to be an ongoing bug with the latest 3.178, unless it's a new undocumented expected behaviour. Could you please confirm in that thread perhaps if the issue with BTT not activating automatically is a new expected behaviour?

Thank you.

Thanks. I updated to 3.186 & managed to export/import my settings. All works now. I will also reply to the other thread about the separate issue.

Imprint | Privacy Policy