Touch Bar keys keeps hiding everytime I switch between apps.

I am a heavy user of Finale, and saved all my shortcuts for Finale on BTT touchbar settings.
Touch bar keys used to show up everytime I comeback to Finale after switching to other apps,
but somehow they don't show up these days. I have to manually turn them back on.
I use 2016 MacBook pro 15', on latest version of Mac OS, Version on Finale, and latest version of BTT.

maybe you disabled btt for final cut pro by accident? click on the btt icon on the top menu bar to check.

I use music notation program named Finale, not final cut pro. Haven't disabled it.

ah ok. maybe @Andreas_Hegenberg can fix this issue then.

Solved! I manually changed Touchbar configuration from Default to Show BTT touch bar.


I'm having problems with this too. I updated to 3.172 & had this issue. Rolled back to 3.148. Now, 3.178 has the same issue.

More than that, 3.178 is pulling an old config file & not reflecting the custom changes I made in 3.148. I can't seem to get 3.178 to work with the configurations I had made in 3.148.

Sequence of events: Updated 3.148 to 3.172. Found issues. Deleted 3.172 & reinstalled 3.148. Made lots of changes to configurations. Updated to 3.178. Found all new changes made to 3.148 had been removed & old configuration (as at the time of update from 3.148 to 3.172) is being used.

As far as I understand this, it might not be a bug. You may just have hidden the Touch Bar. (does the BTT menubar menu show a message about the hidden Touch Bar when clicking the menubar icon?)

If you want the Touch Bar to always show for specific apps, regardless of the current Touch Bar visibility state, make sure to set the appropriate app specific setting here:

Possibly also update to 3.180 alpha if you are still encountering issues. I haven't had many issue reports for >= 3.178, so in general it seems to work as expected.

Just updated to 3.186. It appears to have reverted to the old settings of 3.148, so it seems that there was a bug in the 3.17x versions. The custom touch bar now appears when switching back to the customised app.

Is there a setting in BTT where it can just force BTT to always show and 'disable' bridgeOS? Please, it's so annoying