Three-finger click for Middle-clicking on Mojave doesn't work

Describe the bug

No click happens, with either of the input devices below. BetterTouchTool also crashes most of the time when I try it.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Pro Trackpad and Magic Trackpad

Device information:

  • Type of Mac: 2017 MacBook Pro
  • macOS version: Mojave
  • BetterTouchTool version: latest alpha and non-alpha

Sounds like you are on a older Mojave beta. Is that possible?

1 Like

I don't know how it was possible, considering I made an attempt at getting the latest beta after it came out yesterday. But you're right! I updated and now things are great again. Sorry to waste your time. Thanks!

Good morning,
Middle click on 3-finger click isn't working for me. I've tried disabling all 3 finger gestures. Magic Track Pad (v1) setting 3-finger click to middle click. Program (openVNMRJ2) responds with left click. Tried 4 finger click, 2 finger, 1 finger, left right etc. Tried system preferences to disable all 3 finger clicks and gestures. No luck.

Imprint | Privacy Policy