stream deck beta: changing the 'activate on key up' named trigger

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
When changing the named trigger in the 'active on key up' setting in a Button trigger in Stream Deck Beta, the change is not applied unless one then disables and re-enables that setting. In all other scenarios that I tried, the change was not applied. Screen recording of the behavior should be attached / below.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
BetterTouchTool settings


Device information:

  • Type of Mac: macbook air, m1 2020
  • macOS version: 14.4.1
  • BetterTouchTool version: 4.479 (alpha)

Additional information (e.g. crash logs, related issues, etc.):

I have the same issue. I solved it by clicking "Trigger named trigger on long press" checkbox on and then off, then it magically saves the state of "Additionally execute a named trigger on key up".
But there is another problem there. All modifier keys (Shift, Control and Option) works, and Command not.