Snap Areas not functioning

I can't seem to get Snap Areas to work in ANY capacity.
I'm able to create new and edit new Snap Areas. I open a sample window to the desired size, configure the zone, etc. After CMD+W, I try to test the snap area and nothing happens - no visible snap are and no window resizing.

I've tried running in OSX Safe mode to rule out any other conflicts and tried with no connected external displays.

I'm hoping that there's s simple setting that I've completely overlooked, but I'm stumped. Can anyone offer some sage advice?


Mh in general there are no special tricks for snap areas. They should appear as soon as you drag a window.

What kind of mouse are you using?

Hi There!

Thanks for looking into this!

I've tried this with both the Trackpad on my MacBook Pro as well as a USB Razer Mamba Mouse.

I installed this preset and that seems to work as intended, using a keyboard shortcut to invoke.
Multiple Monitor Window Snapping (Mainly using keyboard) but I still can't drag a window to a snap zone...


Same issue here. If creating a new area using "current window as template", it works, but as soon as I modify the windows resize area or location, it breaks.

I am having the same issue as the users above.

I recently got a brand new MBP. It has a clean installation of 10.13.6 and BTT 2.626. I did not migrate any data from another Mac.

When I drag the application onto the snap area, the snap area is activated; however, the outline of the resized window does not appear. Releasing the window onto the snap area does nothing. I have tried with multiple apps and multiple snap areas.

On my iMac, my existing snap areas work fine, but newly created snap areas exhibit the bug of non-functional snap areas.

I think btt 2.635 should fix at least some of these issues! (Get via check for alpha updates)

Hi Andreas. I have confirmed that the snap areas are working correctly in 2.635. I had to create new snap areas. Snap areas created when the feature was broken remain non-functional.

I was having the same problem then I noticed it was only certain apps that were not snapping correctly. For example Safari will snap Chrome 69 will not snap using the Windows 7 Style - Windows Resizing. What weird is that if I use the Move Resize hot key (mine is :arrow_up:+[Ctrl] ) to move the window then it does snap once the mouse hits the menu bar, corners or sides. Simply dragging the window by left clicking and holding down does not snap on the top menu bar it does open the desktop chooser