Personal solution needed for magic mouse (3 finger drag? Scroll to emulate mouse drag?)

edit: sold my magic mouse but still need this for my normal mouse scroll. please see comment below

Hi guys. I'm looking for a solution for a personal use case. I am a music producer using Bitwig Studio I just got a magic mouse 2 and want to be able to use it to control the knobs in Bitwig Studio.

To explain how the knobs work in Bitwig, you simply click and hold left-click on a knob, then move the mouse up or down to adjust it.

What I want is to be able to scroll my finger(s) up and down on the mouse and it will adjust the knob.

PS: Bitwig does not let you use the scroll wheel of your mouse to adjust knobs btw. So the solution I am looking for has to emulate the mouse dragging up and down.

Also note that I'm not looking for midi capabilities as I dont want to have to map the knob to my mouse via midi.

So, I have tried a few things already but they didn't seem to work on Bitwig. I understand this might be a bitwig related issue but I want to find workarounds using BTT to try achieve this.

If you are interested in testing on bitwig, you can download bitwig's demo from the site and you don't have to know how to use it, can just find any knob in Bitwig and click and drag it. I'm not expecting people to though, I'm just looking for any suggestions on other workarounds I could try to try get what I want working.

One thing to note, when clicking on a knob, the mouse cursor disappears until released. This is to ensure the mouse remains in the same position it was before. . It's fundamentally how bitwig works and cant' be changed in bitwig. I am thinking this might be the reason things aren't working.

Let me go through what I've tried:

  1. I enabled "magic mouse touchpad mode" on the mouse. It works when just using it normally, but when I use it on a knob in bitwig while holding the click on the mouse, or even holding click on the trackpad and then moving my finger on the mouse, the knob doesn't move at all and when I let it go, it jumps to either the 0 or 100% position.

This is particularly baffling because on the trackpad, you can easily hold click and swipe up/down and it works perfectly.

  1. I tried instead to make a finger swipe down to trigger a start mouse drag relative to mouse cursor. It also does a similar thing. I can't smoothly control the knob by swiping up and down.

  2. I have tried to simply start a mouse drag with just a key on my keyboard and then make a 2 finger swipe to only MOVE (not drag) the mouse up relative to the current position, and it also doesn't do anything.

Three finger drag on the trackpad (which can be enabled in the MacOS settings, not in BTT) work perfectly with knobs. Is there a way to enable this feature on the magic mouse? This would be the simplest solution as it works great on my trackpad. I bought a magic mouse thinking BTT will allow me to do the same thing.

Thanks so much in advance for your time

@Andreas_Hegenberg I sold my magic mouse and got a normal mouse, but I'm still having the same issue with my normal mouse scroll wheel.

so the issue it seems is that Bitwig Studio hides the mouse cursor while you're adjusting a knob. So if I do "move mouse relative to cursor position", it doesn't work.

On windows, autohotkey was able to still move the mouse despite the cursor being hidden. Is it possible to do this on BTT?

to re-iterate simply what I need: in bitwig studio, while simulating a mouse drag on a knob, I need to scroll up or down and have the mouse move up or down when scrolling.

You should be able to use the "Move Mouse To Position" action relative to the current mouse cursor position:

thanks but as I mentioned, I have done this as you've shown and it didn't work. It's probably because Bitwig removes the mouse cursor when adjusting knobs, but I was able to do it in Autohotkey when I had windows, so there must be a way. I recommend just downloading the bitwig studio demo here and just trying it on any knob Try | Bitwig

@Andreas_Hegenberg bump :slight_smile:

Sorry, if that doesn't work I'm not aware of any way to make this work on macOS ;-(. (Windows is completely different)

Most likely it would require custom code to make this work. Possibly try to record a macro using the macOS Automator app - maybe this will work. Possibly bitwig has an Apple Script interface that could be used instead of simulating mouse events?
They mention this:

A scripting guide and API reference resides in Bitwig Studio under Help > Documentation > Developer Resources.


sorry for the late reply. thank you for putting in time for this. its a big shame this doesnt work. i thought since autohotkey could do it on windows that it'd be possible on mac. ill look into the other solutions you suggested

thanks for your time