Move Windows w. Modifier Keys - Not Working

Describe the bug

Settings > Moving & Resizing Modifier Keys > Move Windows

I have tried every combination of modifier keys possible, and I am still unable to Move Windows using modifiers. Nothing happens. Oddly enough, however, the Resize Windows setting still works perfectly fine. The bug only seems to impact the Move Windows setting.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.): trackpad, mouse, etc.

I've tried numerous settings, but theses are my current ones:

Device information:

  • Type of Mac: MacBook Air (13-inch, Early 2015)
  • macOS version: Monterey 12.3.1
  • BetterTouchTool version: 3.763 (1904)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.): I have quit or disabled every app that I could think that might conflict with the Move Windows setting, and nothing has worked. I also made sure to test with and without my external monitor ... and I've tried numerous other things, like only using the Move Windows modifiers (and not Resize Windows). At this point, however, I can't think of anything else. This appears to be a BTT bug. Thanks for any help you can lend.

can you go to help-> export diagnostic debug information (menubar menu) and send the result to Then I can check whether it’s caused by some setting.

Thanks for the quick response, @Andreas_Hegenberg !!

I just emailed you the requested diagnostic info, but if you need anything else, just let me know. Thanks a ton!

Hi @Andreas_Hegenberg - By chance, were able to find anything wrong in the diagnostic info I sent you? Any ideas what might be causing the bug here?

As I said before, resizing windows with modifier keys still works great. It's just the ability to move windows with modifiers that has been impacted.

I've continued to test different things on my system and with BTT, but have not had any luck isolating the problem. It's driving me crazy. Ha

In any case, thanks for any help you can lend!

@Andreas_Hegenberg I'm not sure if it's relevant, but I tried to take your advice here, and create the two BTT actions for moving windows that rely on clicking the mouse (just as a temporary thing until things get fixed). However, it didn't work either.

Interestingly, similar to the global setting for resizing windows with modifier keys, the resizing actions worked perfectly though.

As a result, the bug appears to be impacting the individual actions for moving windows (start/stop, etc.) and the global settings for moving windows with modifiers alone.

Any ideas what might be going on here? Thanks!

Hi, I'm sorry to resurrect this post after such a long time.
Both moving and resizing appear to have stopped working for me.

Below is my setting:

I have restarted BTT but it doesn't help.

Any ideas about the solution?


MBP 14
macOS: Ventura (13.5.2)
BTT version: I was on 4.271 and upgrading to 4.272 does not solve the problem.


Same issue
MacOS Sonoma 14.0

Sometimes when upgrading to newer macOS versions, macOS breaks its permissions database. Try to remove BetterTouchTool / BetterSnapTool from System Settings => Privacy & Security => Accessibility (really remove, disabling is not enough), then add it again. Make sure to quit the app before doing this.

I did it but it did not seem to fix it.
I did it in two ways. One way is like what you instructed, remove it and then add it again. The second way is to remove it and relaunch BTT and did it under BTT's prompt.

This has resolved the issue.

Edit: said to early. The function will randomly stop working again after some time. I have reinstall BTT. It works again after the reinstallation but stopped working again after some time. I say "randomly" because I don't know what was the cause.