Mouse Scrolling Can't be Detected or Triggered

Describe the bug
The actions with my normal mouse scrolling cannot be triggered.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Normal Mouse (Wireless, Logitech M590)

Screenshots

Device information:

  • Type of Mac: MacBook Pro (15-inch, 2017) with Touchbar
  • macOS version: 10.13.5
  • BetterTouchTool version: 2.536 (871)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
(1) Action with left click or right click works
(2) I have installed Logitech Options in my mac, the official mouse management software of Logitech. But there isn't button mapping for scrolling.
(3) When I test with another wired mouse and no related management software is installed, the action with scrolling works. I am not sure whether the conflict between Logitech Options and BTT causes the problem, or the inability of BTT detecting the scrolling of this mouse.

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Hi,
Was this ever solved? I am having the exact same issue and can't find a solution.

1 Like

+1 I am having the same issue on the most recent versions.
@Andreas_Hegenberg, someone? Will this ever be fixed?

I really miss my scrolling to reveal/hide an app functionality from HyperDock (RIP).

I found out some more information:
Ccrolling triggers work with my Razer Orochi mouse, but they do not with my Logitech MX Master (Mark 1). The scrolling is still recognized in the Click to record a mouse button: applet. But it is not recognized while scrolling in macOS

1 Like

exactly same with me

Hi,

I would also like to use scroll events from Logitech mice as triggers. BTT detects the scroll event when assigning to the trigger in the UI, but the assigned action never occurs.

I have a similar goal as @qfc13 - I want to map "^ + Scroll Up" to a zoom keyboard command.

I'm getting the same problem. Scroll gestures are recognized by BTT, but they actually don't carry out any function for some odd reason.

I'm fairly certain that with Logitech mice this is due to Logitech Options, or other Logitech software. When I use Logitech mice without any software installed, I don't have this problem (though most of the mouse buttons don't work, so it's not a solution).

I still would call this a BTT bug, though, because in the configuration UI scroll events are detected. That is, when registering a scroll event trigger, BTT always recognizes the scroll. But these trigger/action pairs do not work once set. (Again, all of this is only when the Logitech software IS running.)

I can confirm this

Imprint | Privacy Policy