macOS Control Center - MCC

Hello yw4z, thanks for your fast response.

I enabled/disabled the checkbox and restarted during this action. Sadly the bug is still there. Same bug occurs on the other extension from you for window management (SWM).

I am using an iMac End 2012 27" (Intel Core i5-3470S, 16GB, NVIDIA GeForce GTX 660M 512 MB, OS X 10.13.6)

Here the script result:
➜ networksetup -listallhardwareports

Hardware Port: Ethernet
Device: en0
Ethernet Address: 10:dd:b1:b8:bd:b0

Hardware Port: Wi-Fi
Device: en1
Ethernet Address: 8c:2d:aa:56:c3:20

Hardware Port: Bluetooth PAN
Device: en4
Ethernet Address: 8c:2d:aa:56:c4:2c

Hardware Port: Thunderbolt 1
Device: en2
Ethernet Address: 32:00:10:b3:36:20

Hardware Port: Thunderbolt 2
Device: en3
Ethernet Address: 32:00:10:b3:36:21

Hardware Port: Thunderbolt Bridge
Device: bridge0
Ethernet Address: 32:00:10:b3:36:21

VLAN Configurations

@CodeBrauer thanks for submitting result, you can delete ehernet adresses if you have privacy concerns, i need to write a script to recognize which device using which port,
does your bluetooth toggle working ?

if you can edit html file

var wrs = await ShellScript(`networksetup -getairportnetwork en0`)

var sc = 'networksetup -setairportpower en0',WDisable = sc+' off',WEnable = sc+' on'

changing these 2 lines to

var wrs = await ShellScript(`networksetup -getairportnetwork en1`)

var sc = 'networksetup -setairportpower en1',WDisable = sc+' off',WEnable = sc+' on'

should fix wireless toggle, i will add a setting for selecting which device to toggle on next releases

webview is not applying clear background css on some setups, its same with mcc and swm related post

will attempt later if you still need, though im not very good at finding my way around code...

@Future_Face dont be hurry :slight_smile: i shared edited file on previous post, you don't have to edit code, just replace file and don't forget to backup original one, replace back original if will not work. let me know if this will work

this download didn't work—you've put it as a .html file

click this folder icon in bettertouchtool then replace file, thanks for your help, i hope this will fix it, did you try with disabling aqua touch

thanks, but I couldn't even download the edited file that you aired with me, because you shared it with .html

Updated first post with 0.7.1 release


  • New - KEYLIGHT Toggle for Keyboard backlight with increase/decrease buttons.
          Move your cursor to icon for + / - symbols;
          + Increases keyboard backlight with 2 steps,
          Right clicking + increases keyboard backlight brightness to maximum level
          - Decreases keyboard backlight with 2 steps,
          Right clicking - dims keyboard backlight to 0

  • New - MICOFF Toggle for Microphone Mute / Unmute with dynamic icon. Right click opens microphone settings. Some chat apps can change mic level without asking, check icon on for a while before using

  • New - Display Mirroring toggle icon is now dynamic
          Single Display MIRROR / Mirrored Display MIRRORM / Multiple Display MIRRORD

  • New - Swipe / Scroll on sliders to set your volume or brightness level. Working smooth with trackpad but got some lag with mouse scroll

  • New - SIRI Siri icon changed

  • Improvement - Faster load on startup

  • Improvement - Control Center automatically detects primary Wi-Fi device port for older macs that not using en0 port

  • Updated future plans

fyi, I tried doing what you said again, and now it works. thanks!

@Future_Face its great, have fun

@Andreas_Hegenberg multiple requests for now playing from different presets crashing btt. aquatouch and control center couldn't work together until now playing feature disabled on one of them

1 Like

weird, do you have a crashreport?

@Future_Face can you share crash report with Andreas, maybe both presets fully working after fix

how do I do that?


1- Open Console App then click User Reports in sidebar
Right click to BetterTouchTool related files then select reveal in finder and collect all in a folder

2- Open BetterTouchTool then select Help > Export Diagnostic Debug Information to Desktop from menubar

share all files with mail, thanks for help

1 Like

The calculator button doesn't work. When I click the icon nothing happens even if I already have the calculator app open.
I'm currently on Maccos Big Surr with the newest version of MCC.

Hello all,

bad news, im not developing MCC anymore

good news, im developing a new preset as menubar app to complete missing features of control center. i will release it after some testing. its about to finish and all functional. i will release within next weeks. here is a preview

you can follow progress of new preset from this topic

@RockFrog i was removed calculator shortcut from new app, but i will add again with fix

Hi yw4z!

Just letting you know that I've borrowed some of your pretty amazing applescript code to fix some of AquaTouch's controls. (night shift, true tone, bluetooth)

Is this alright with you? I've credited you and your preset in code comments.

While I was doing that I found out that your DND code wasn't working too, and I have no idea how to fix it!

it's ok mate, appreciated credit

i was used btt predefined action 200 in preset on my last build but didnt release it.

i tested it on big sur but its not working @Andreas_Hegenberg

tested my previous applescripts for DND but all not worked
i guess they changed code after big sur. and they changed again on monterey reddit link

so i wrote a new one probably it will work big sur and later. maybe it will work on previous versions too if you use main monitor resolution instead of clock position
option + click notifications icon toggles DND on catalina & mojave
option + click clock text toggles DND on big sur & monterey

but it will not work if user uses a custom clock app

tell application "System Events" to tell process "ControlCenter" to tell menu bar item "Clock" of menu bar 1 to set {sX, sY} to position -- gets position of clock

set p to "{" & (round (sX + 20)) & ", " & (round (sY + 10)) & "}"

tell application "BetterTouchTool"

trigger_action "{"BTTPredefinedActionType":154}" -- save mouse position

trigger_action "{"BTTPredefinedActionType":153,"BTTMoveMouseToPosition":"" & p & ""}" --move cursor to clock

delay 0.1

trigger_action "{"BTTPredefinedActionType":88}" -- click with option

delay 0.1

trigger_action "{"BTTPredefinedActionType":155}" -- restore mouse position

end tell

1 Like

my DND action is working, but my icon display isn't.

im just using the standard BTT action.

yep i tried btt action now its works

i guess this will work for big sur & monterey & mojave

if (system version of (system info)) > 10 then --check OS version

-- will work on big sur & monterey

if (text -3 thru -4 of (do shell script "defaults read dnd_prefs -data")) is "7c" then

return 0


return 1

end if


-- didnt tested backward compability, but it was worked on mojave

return ((current application's NSUserDefaults's alloc()'s initWithSuiteName:"")'s boolForKey:"doNotDisturb") as integer

end if