macOS Catalina 10.15 - Compatibility Issues & Discussions

working fine here on beta 5, maybe try to download a fresh copy via https://folivora.ai. If that doesn’t help, please attach a crashlog!

Still happening after fresh install and unfortunately nothing is showing up in console. The process jumps to 80% CPU while its opening and closing repeatedly.

have you checked the crashlog section in the console app?

I've got quite a few for the Touch Bar Server but none for Better Touch Tool. Can I send one of the former?

mh no that won’t help, the TouchBarServer on catalina also crashes without BTT :grinning:

maybe try to kill the BTT watchdog process using

killall BTTRelaunch

No matching processes were found :slightly_frowning_face:

Have you already tried to restart your machine?

Yep but just did again... Not seeing the flashing BTT icon on Touch Bar anymore, nothing comes up at all actually. Four processes show up in activity monitor for a moment but then go away. Nothing in console either!

Very weird, there really should be something about BTT in the console :man_shrugging:

Maybe try to reset BTT by deleting/renaming the settings folder (~/Library/Application Support/BetterTouchTool )

Or maybe it's the old Mojave Accessibility bug again (https://folivora.ai/blog/post/13005 )

The accessibility trick fixed it! Thanks for your help :slight_smile:

Ahh good to know... I thought they fixed that on Catalina, but apparently not :man_facepalming:

I had the same issue and the Accessibility remove/readd suggestion was what fixed it FYI. Just reporting in to say so. BTT has become a total necessity for me so I'm glad that was all it was!

I completely removed it (I used AppCleaner). Then I rre-downloaded and reinstalled, and I had no more issues. The only odd thing that happened afterward was that I couldn't turn off the System Touchbar, but I sorted that in the Keyboard prefs

I just started experiencing some seriously weird behavior a few minutes ago. BTT is missing from the menu bar, and is no longer taking over the Touch Bar. When I try to launch the app it shows "Preset: (null)" and attempting to use the "Restart BTT" option throws an error that asks me to launch BTTRestart.app, but launching this doesn't seem to fix the underlying issue.

I thought maybe I needed to set my preset again, so I made an empty preset and then tried to check mine back on again. But this caused BTT to crash: BetterTouchTool_2019-08-07-143748_Lancer.crash (96.0 KB)

I'm not sure why this started but now I literally can't use BTT on this machine :frowning:

Have you tried to restart your machine? Sounds like some code sign issue (these usually go away after restarting the mac).

I'll fix that crash with the next build (although it should not happen under normal circumstances)

Restarting did not fix the issue. I’ll try reinstalling BTT?

Mh not sure whether that would help.

However maybe try https://bettertouchtool.net/releases/btt3.173.zip as this should fix the crash you posted above.

Preset: (null) usually means that the selected master preset is not available anymore (I don't know why that would happen though) and that a new one should be selected.

1 Like

New version is working for me!

A heads up @Andreas_Hegenberg that 3.173 does not fix the calendar widget spacing issue.

Imprint | Privacy Policy