macOS 10.13.4 Freezing with BetterTouchTool Usage

Describe the bug
Since installing BetterTouchTool my MacBook has been freezing up for up to 30 seconds at a time at seemingly random intervals. Any known issues with BTT that could be causing this? I'm using a lot of key remapping and the window snap support but not much else.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • macOS version: 10.13.4
  • BetterTouchTool version: 2.503

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

I haven't received similar reports, thus I currently don' think this is related to BTT (or if it is, only in combination with some other specific setup).
How do the freezes look? Can you still move your mouse? Is it the complete Mac that is freezing or specific apps?

Yeah I was surprised because I haven't heard anything like this happening with BTT. Could be something else going on but it does coincide with the installation is all.

The freezes are complete: no mouse movement and video playback will freeze if it happens to be playing. Any help would be much appreciated!

Ethan Kusters

Hi Ethan,

complete freezes don't sound like something BTT could cause.
Do you have some special USB hardware attached? If so I'd try to see whether removing that fixes this, most of the time something like this is hardware related.

Hi, i am also have freezes bug about one times a day after update to macos 10.13.4, its suddenly happen, its will freezes whole mbp about 15-20 sec when switch application or move the trackpad at finder, i tried to force quit all apps but still freezes untill hold the power button to restart,.
Today the freezes bug happen, i try to quit bbt first and the freezes gone, i think it is a clipboard problem.

Hi! A few weeks ago I also started having these random freezes... I also believe that they're BTT related...
My mouse freezes completely for 10-20s and after it comes back, it freezes again after 5-10s. I noticed that when I restart BTT, it stops (at least for a few days...).

I don't know how I can find out if it really is BTT related, but that's what I initially believe...

I'm running MacOS 10.13.5 on a 2016 MacBook Pro 15-inch.


I also have this issue. It was very weird. The mouse will freeze every time you move to a new window or application. In fact it is no just the move. If you cmd-tab to switch apps then it won't work, keep tapping the keys and you will know when it is back working. I used this method to quit apps thinking once I quit one of them it will all return. Nothing changed. Once I quit all the apps I started on the "hidden apps". As soon as I quit BTT it all came back. Immediately reopen and all is good again.

I have a Magic Trackpad 2 and also run Bartender. I also use a lot of Desktops over two monitors. I am running 10.13.5. If there is any information I can provide, I am more than happy to do so.

I have the same issue, currently running BTT 2.252 Alpha on 10.13.6 B3.

Has happened twice now: once about four days ago, which I resolved with a reboot. Then again today, which I resolved by closing BTT. It has not yet re-occurred after re-opening BTT.

As others describe, I sometimes get near-total freezes (mouse pointer won't move, keyboard input ignored) when switching applications. For me these freezes last 5-10 seconds.

But in my case it does not seem to apply when switching windows - at least, it didn't when I tested between multiple Firefox windows. But it always happened when switching to another app, eg by clicking on its window or its menu bar icon, or by closing the current app such that another becomes focused.

In terms of USB hardware, I have:

  • Magic Trackpad 2 (not currently using Bluetooth for this)
  • Behringer UMC404HD external sound card (4 in/4 out)
  • Keyboard (PC style, 102 keys, Windows keys etc)
  • My Eizo monitor, which is only used as a USB hub but still shows up in the USB Device Tree
  • a USB-to-serial adapter: FT232R USB UART

Here's my USB device tree:

I run a number of background apps:

  • Karabiner-Elements
  • Bartender
  • TotalSpaces
  • Alfred
  • Hazel
  • iStat Menus

Always open foreground apps:

  • Firefox (multiple windows, including one usually playing video)
  • iTerm 2 (multiple windows)
  • Wavebox
  • Microsoft Remote Desktop
  • Activity Monitor

I was going to Gist my logs then I realised they have license details in them. How should I submit them?

Thanks @TheBloke for the details!

I currently assume this may be caused by some sort of conflict with some other app (possibly with one that installs a kernel extension). I don't think there has been any recent change to BTT that could cause something like this, but it's very possible some other app got an update that doesn't work nicely while BTT is running.

Can you maybe find a common app that all of you have installed?

In general mouse movements are handled at a lower level than BTT can interact with, which is why I assume the originating issue is not BTT.

Logs can be sent to be via!

From the list @theblock submitted, I have

Microsoft Remote Desktop beta

If we need to swap a full list happy to share

Some more details about my setup:

I also use an external monitor: Dell P2317H, which has a USB hub.

I use a wireless mouse, which runs with a dongle connected to the monitor's USB Hub, and a Bluetooth Keyboard from Anker.

Regarding apps, I have these running on the background:

  • Alfred 3
  • iStats Menu
  • Flux
  • Yoink
  • Magnet (window management)

Always open on the foreground:

  • Wunderlist (with Wunderlist helper on the menu bar)
  • iTerm 2
  • 1Password (with helper on the menu bar)
  • Safari

I hope this helps... If there is other information you need, please let me know!

Edit: I also have my bluetooth headphones connected all the time.

Hello, I faced the same issue a couple of days back, and I had some more issues along with it.

  1. OS hanging with mouse pointer stuck. Repeats every few seconds.
  2. Every 30 mins the Dock application crashes and CMD+Tab switcher doesn't work anymore, including gestures to show desktop and spaces as well.

I turned off BTT and been testing this since the last 36-48 hours. No issues yet. I'll turn it back on and test again to confirm.

No external USB devices used.
No special software running that has accessibility privileges.

Other software:

Microsoft Remote Desktop - Installed, but not running.
Cisco VPN

Same issue here with macOS 10.13.5, it takes a long time to find the real culprit.

As soon as I manually quit BetterTouchTool, system returns to normal.

Right after this happens please go to the about tab in BTT and click the "export debug information" button. This will create a folder called BetterTouchToolDebug on your Desktop. Would be great if you could send that to
Maybe there is something in the logs that could explain this.

Also if you are on the latest alpha you could try this command to disable some functions that are called when switching apps. BTT must be quit before running this terminal command:

defaults write com.hegenberg.BetterTouchTool BTTDisableSecureInputLookup YES

I've just had my third occurrence. I've emailed the BetterTouchToolDebug folder.

In my earlier reports I forget to list Path Finder amongst my always-open foreground apps. And I may have noticed a pattern: tonight the issue started just after I switched to Path Finder. And I am 95% sure that at least one of the other two occasions also started after switching to Path Finder. The first time it happened I remember thinking that maybe my SSD was failing, causing the system to lock up, because it happened right after I clicked onto Path Finder (which I thought maybe had caused some extra disk activity or something.)

Can't be sure about the second time, it may or may not have been after a Path Finder switch on that occasion. I'm running the latest version of Path Finder, version 8.0.3.

If it is Path Finder, then it's certainly not every time or anything like it, because I click onto it many times a day.

Hopefully my logs will show something. I will now try the Secure Input disable, to see if that prevents it happening again.


Unfortunately these logs don't show any error :-(. However I have added some more logs to the new version (2.530), I hope these will provide more insight into what is happening.

In case there are any crashlogs or similar, that would also be very helpful!

Sorry, I've been away and not following this thread. Which version should I run to help with logs?

I had to put this here as I am limited to 3 replies

Mine is just as others describe. A quit of Better Touch Tool and reopen is fine. I will send a sample when it does it again. I had the issue 3 days running almost 24 hours apart before that it was all of a sudden. If it helps I have 2 desktops on the 27" iMac and one on the external display. I also have 4 apps in full screen mode, 3 on the iMac and 1 on the external display.

It's fine for a random amount of time (in the range of hours), then it freezes every time a window changes focus. Does not happen for “small/utility” windows such a status bar apps.

I've reproduced it with 2.530 (865). I'm confident the freeze happened at this time interval:

1530177966.728942|swi|check device class|
1530177966.728949|swi|shortcuts NOT used|
1530177981.743568|short|register all hotkeys for current app|
1530177982.446126|swi|check device class|
1530177982.446130|swi|shortcuts NOT used|
1530177997.457854|short|register all hotkeys for current app|

I've printed a timestamp at 1530177966 in iTerm, then switched to another window and then back to iTerm at 1530177998 for a total of 2 freezes, each roughly 16 secs.

One question: after restarting BTT, does it work again for a few hours or do you need to restart your Mac then?

I can see a long timeout when BTT is checking which gestures/shortcuts should be activated for the given app, but BTT isn't doing anything special at this point :-/ (just some database lookups).
If you can reproduce this again, it would be awesome if you could create a sample of BTT using this terminal command (hit enter then switch the window):

sample BetterTouchTool -file ~/Desktop/BetterTouchToolSample.txt