Key Sequences Not Working after macOS 14.4.1 update

Note:
Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Greetings,

Today after installing macOS 14.4.1 updates to an M2 MacBook Air and an M1 iMac24 keyboard shortcuts that are configured the same on both machines are no longer working on the MacBook Air. They work as always on the iMac. These are simple keyboard shortcuts that trigger macOS Shortcuts.

The Better Touch Tool version on both Macs is 4.460|44601

Thanks in advance for any responses/advice.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).


Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):


Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)


Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):

+1 I'm running Version: 4.465 and just updated and restarted my system (which I tried twice before), and I have Command-Option-` set to flip between web browsers when I'm working in them, and notetaking apps when I'm working in them -- so basically Command-Tab for specifc apps on specific Mac spaces. But since the past few versions it will work only occasionally, like maybe once or twice but the third time it won't switch apps, or it just won't work at all.

If shortcuts are not working at all it's most likely a permission issue. Try to remove BTT from System Settings => Privacy & Security => Accessibility, then add it back manually. Sometimes after macOS updates these permissions can get mixed up.

Also make sure BTT is not listed in System Settings => Privacy & Security => Input Monitoring (sometimes macOS automatically adds it there when it shouldn't).

A general change in recent BTT versions is that there is no default delay when sending keyboard shortcuts. If your actions sequences relied on delays between shortcuts, you either need to add delays manually or check this option in the settings to get the old behavior:

Andreas,

Thanks for the quick response. As per your suggestions . I did remove and reinstate permissions for Settings => Privacy & Security => Accessibility and then also made sure BTT was NOT listed in System Settings => Privacy & Security => Input Monitoring. (It was.)

I have also tried things with the add small delay box both on and off and still get the same results on the MacBook Air.

Again thanks and I'm looking forward to your next response.

Warner

Make sure BTT is not disabled for some reason:

If all looks good, I'd try to restart your machine. There doesn't seem to be a general problem with 14.4.1

Ah, one other note, there might have been a bug in older BTT versions where this setting had no effect. (“works on keyboards with same type as used for recording). This was fixed recently, so if you used that option it might cause issues now.

Andreas,

Again thanks for your quick response. Have followed all suggestions. Still no luck.

Weird.
If you want you can go to Help => Export Diagnostic Debug Information and send the result to me (andreas@folivora.ai), then I'll probably be able to see what's going on!

Sent the files to you. Thanks.

thank you!
The debug data only contains key sequences, no normal keyboard shortcuts. Is that correct? I was only able to test the triple left cmd because I don't have the necessary shortcuts to try with the other ones.

I need to go to sleep now, will continue tomorrow.

Andreas,

Thanks for looking into this. Yes, these are key sequences. Sorry for the confusion. As you can see there are only three. None work. Although I kept turning the permissions on and off and an odd thing happened. After turning then off and then back on any of the three would work one time and one time only. None of the others would work following the first one.

Hope you get a good night's rest. Thank you again.

I am having this same issue. None of my Key Sequences are working anymore.

  • I have tried the fix of turning off/on Accessibility in Privacy & Security.
  • I verified that BTT is not listed under Input Monitoring
  • My sequences do not need any delays
  • I have confirmed that BTT is not disabled. In fact, Keyboard Shortcuts still work fine.
  • My Trigger Condition is set to "Works on all keyboards"

Should I also submit my Debug report? If so: how?

AH! I tried restarting again and that seems to have fixed my Key Sequences!

i‘d try to reset all permissions for BTT, there doesn’t seem to be a general problem with key sequences (which is why I assume it’s some sort of permission issue)

Run this terminal command while BTT is quit:

tccutil reset All com.hegenberg.BetterTouchTool

The issue started again. Keyboard Shortcuts work. Key Sequences stopped working.
I quit BTT and ran the above terminal command (fixing the typo). Then I relaunched BTT.
It asked for all the permissions again, which I granted.
But it still doesn't respond to Key Sequences.

are you using the standard BTT version or are you using it through the SetApp subscription service?

Standard.