Keep getting stuck in a disabled state on Sonoma

Describe the bug
BTT keeps getting stuck in a disabled state since upgrading to Sonoma. I've tried enabling both settings related to secure input, but it stills ends up disabled with either and both enabled.

Usually it's just the keyboard shortcuts that are disabled. Though a few times something has gone wrong with the touchpad input as well where that seems to also be in a disabled state and I am unable to click until quitting BTT.

I've tried isolating which app might be causing secure input to be triggered. It seems like it might be Chrome. But I'm not entirely sure about that. Let me know if there's a way to diagnose that better. Also if there's any way to get logs from BTT related to when it is disabled.

A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Sometimes trackpad


Device information:

  • Type of Mac: Macbook Pro Apple M1 Max
  • macOS version: Sonoma 14.1 (23B74)
  • BetterTouchTool version: 4.317 (43170) (Regular release channel)

Additional information (e.g. crash logs, related issues, etc.):

Have you maybe accidentally enabled the "Disable BetterTouchTool completely" checkbox for either "All Apps" or a specific app?

This could also be related to this:

Would be great if you could go to Help => Export Diagnostic Debug Information and send the result to

Thanks Andreas!

Nothing disabled:

I manually added BTT to the Input Monitoring list under Privacy & Security and that seems to have resolved the issue, at least so far :crossed_fingers:

Is it supposed to have that permission and just got removed it on my system?

Thanks for the info on debug info. I'll send that over if the issue happens again.

If you have given the Accessibility permission (which is important for BTT), the Input Monitoring is not necessary and can even cause some issues :slight_smile:
BTT will automatically try to remove the input monitoring permission when it starts.

Interesting, so far the input monitoring permission hasn't been removed (tried restarting a few times). Accessibility permission is also granted. I've unchecked the input monitoring permission and will see if the issue reoccurs.

unchecking it is bad :slight_smile: it should be completely removed.
Unfortunately these permissions are messy ;-(

However if everything works for you, you can also leave it enabled.

Thanks, removed the permission completely and the issue reoccurred (after waking from sleep, maybe BetterTouchTool is currently disabled (see below) is related). I've sent the debug info and logs to Thank you!

As an update, the input monitoring permission was a red herring. Even with it granted BTT is still disabled when waking from sleep.

could you try the 4.321 alpha?

:+1: giving it a try thanks!

Sadly still having the same issue. Sent over more logs.

1 Like

I am having as best I can tell the exact same issue.

Type of Mac: Macbook Pro 14-inch, 2021 with Apple M1 Pro 
macOS version: macOS Sonoma 14.1.1 (23B81)
BetterTouchTool version: 4.318 (43180) (Regular release channel)

I also checked and I did not have anything disabled under Global (App specific settings). I have removed and re-added the accessibility permission without any improvement.

1 Like

From the logs I received I think I noticed two common things:

  • Restart after wake from sleep was active
  • The experimental dropbox or icloud sync was active

Could you try to disable those?

1 Like

@Andreas_Hegenberg I think you've identified the trigger. I'm running Sonoma on a M1 Air.

For the options

  • Restart BTT after wake from sleep
  • Enable sync

If I disable either of these (or both), I get expected behavior / not stuck in disabled mode after sleep.

With both enabled (my existing config) I can reliably reproduce "disabled after sleep" on BTT 4.318 and 4.321

EDIT: When I disable "Restart BTT after wake from sleep" I intermittently get issues after resuming (which is why I had turned it on in the first place). But this is not every time I resume, and not as obvious -- the BTT menu doesn't indicate it's disabled, but my hotkeys don't trigger.

+1 with both disabled I haven't seen the issue recur so far.

Do you have different way you recommend for syncing the settings? E.g. could I symlink a config file or would that be problematic?

Having the same issue, I'll try disabling sync + restart from sleep. It started happening for me with the last OS update.

Also as a possibly related note I noticed when BTT was disabled keyboard input was a bit weird, in that keypresses would go missing. I thought it was me, but apparently something was eating keyboard input?

I'm also having the same issue. I'll try disabling sync & restart from sleep and see if it continues. M1 Mac on Sonoma.

Nope. Now whenever it loads, it immediately grays out and says "BTT is currently disabled. See below." (I'm not sure what the see below is referring to.). I've sent my logs to you, Andreas.