BetterTouchTool is currently disabled (see below)

Hi there,

Happy user for a while, I now have to restart but almost each time my Mac go to sleep.
it looks it's broken for something like 3 weeks, even on the last version (4.317). It was fully functional before (priority helper was installed a while ago, etc) and I'm currently on Ventura (13.4).
Interestingly, when it happens, the setup panel (where I define actions for the trackpad), show no configured actions. Restarting btt restore full functionality.

When the problem occurs, the menu does not display those options :

  • restart btt
  • quit btt
    and the last entry in the menu is : "disable btt for"

Does there is anything I could collect that would help to troubleshoot ?

I've got a very simple setup, I don't mind to loose settings if this could help.

There is no crash as far as I see, and I'm using a MacBook Pro 14" M1 with the integrated trackpad as the only used features.

thanks in advance :slight_smile:

just checked :

  • restart btt after wake from sleep is checked
  • the priority helper is not installed any longer. just installed it back and restarted btt to check.

I'll report if this improve the situation.

mhh I can't tell too much from your logs, but I think somehow BTT is getting confused with your licenses.
You have one old license from 2016 and one new life time license. For some reason I think BTT still tries to access your 2016 license. That's probably a bug, I'll try to reproduce this here.

Could you try to delete the old license file manually and see whether that helps? The license files are located in ~/Library/Application Support/BetterTouchTool (go there via Finder => Go => Go to Folder, make sure to include the ~).

I would recommend to delete any file ending with .bttlicense. Afterwards you can import your current license again by double clicking the license file or clicking the activation link.

Also I would recommend to disable the experimental iCloud sync. It could also cause issues like this.

thanks for your reply.

Deleted the old license and deactivated cloud sync.

For now, the problem isn't happening any longer, I'll report in a few days.


I'm seeing this too occasionally during the last few weeks, currently running 4.318 on Sonoma 14.1.1.
I checked the ~/Library/Application Support/BetterTouchTool directory and I only see a single license there (which is also from 2016).
I had iCloud sync checked as well and now unchecked it. Lets see if this solves it...


what's likely made it for me, what to ensure that the process priority helper tool was installed. It was for a couple of years, but something likely uninstalled/deactivated it.

hope that may helps.

Thanks for the tip! I just checked and also needed to reinstall the helper tool.


tl;dr: I disabled cloud sync and it fixed the issue

I started having this problem recently as well.

  • I checked for extra license files, but none exist.
  • I deleted my license file and reactivated my license and it didn't fix the problem.
  • I've never used the helper tool, but I installed it anyway and it didn't fix the problem. I uninstalled it.
  • I don't use iCloud for sync, but I do use Dropbox. I unchecked "Enable Sync" and that seems to have done the trick. I've slept and waked my system a few times and things are still running great.
1 Like