Hyperkey unusable

After thinking about it more, I believe I have the same issue: only Hyper Key + Arrow Key is non functioning. Everything else seems to work fine.

have you tried configuring these shortcuts in BTT and then teiget keyboard maestro via some other activation option? BTTs hyper key works best if the shortcuts are configured directly in BTT

Hello @Andreas_Hegenberg, thanks for the reply. I have tried some of my window management through BTT as you suggest, and using the arrows with shortcuts in BTT does work fine. It means for me to rework my window management shortcuts but its possible. Not ideal, but possible.

Thank you!

Ah I didn't mean to reconfigure the window snapping functions in BTT but instead to call Keyboad Maestro vom BTT.

For example you can trigger Keyboard Maestro using the url trigger:

Edited, see below.
For now, I have changed the Moom shortcuts (Hyper + Arrow Key Up to maximize, H + Left to move window to the left, H + Right for the opposite and H + Down to restore window size) to Hyper + I, J, K and L respectively. This works great, but optimal would of course be to be able to restore the arrow functionality.

I tried this, and it works fine. But it would be nice to be able to keep window management (both popovers and keyboard shortcuts) in one app.

I've tried what you've suggested here, with a simple Caps-Lock M trigger that runs a Keyboard Maestro closing the side windows in OmniOutliner.

However, after opening the side windows, it consistently requires two Caps-Lock M presses to work. The mouse cursor flickers once on the first press, and on the second press, the top of the window and right side menu (inspector) flickers badly before the menus close.

But to be clear, your suggestion involves building a trigger in BTT for every Keyboard Maestro macro that uses the caps lock? (I have over 100 across all my apps, and it might not be worth it.)


P.S. I'm using the second line of Keyboard Maestro's "Or by URL" window in the BTT "Open URL" action-- is that correct?

I've been having the same issue as well every since I moved off of Karabiner. Pretty much every time I ran a shortcut that used the hyper key in BTT, the hyper key would get stuck and I'd have to hit capslock 2 or 3 times to deactivate it.

Crossing my fingers, but I think I might've found a solution.

Just remove the hyper key shortcut and re-add it.

I'm having the same (or similar) issue as @taulars describes. When I press Caps Lock acting as a Hyper key it freezes up my keyboard entirely more or less every time, making the shortcut unusable. I had similar issues on my previous Mac but only occasionally. Only way to fix it is to repeatedly hit Caps Lock and hoping it will work.

Is there a reliable fix for this behaviour?

macOS Big Sur (11.6.1)
MacBook Pro 16" (2019)

v3.615 should fix the hyperkey issues

Thanks for such a swift response. Indeed, the update seems to have fixed it :pray:

I am trying to use Hyper-J, Hyper-K, Hyper-L, Hyper-; as substitute for arrow keys (respectively ← ↓ ↑ →). I then use BTT's "Repeat assigned action while pressing" to simulate holding down the arrow keys. The intended action is like this, the cursor moves:

Manual vim cursor

This is indeed what I get when I do ⌃⌥⌘J, ⌃⌥⌘K, etc. But when I do Hyper-J, Hyper-K, etc. what I get is the cursor stopping after about 0.5 second, until I press the combination again:

Hyper vim cursor

If I don't repress the shortcut (Hyper-J), the cursor stops moving completely. I must repress the shortcut constantly to get it to move like in the above gif.

Why is Hyper-J etc. not acting like ⌃⌥⌘J etc.? All shortcuts are defined in BTT.

1 Like

Even trying to rerecord the Caps Lock as outlined in help is non-functioning. Has been working well up until this morning. I did verify that the Caps Lock is not remapped in. the keyboard settings.

Sorry, it may be me, but I don't understand why people don't just use the BTT feature that allows right control to be used as a hyper key.

Some keyboards do not even have a right control key. Like my MacBook Pro. Which makes it difficult to use.

This is a misunderstanding. I also have a Macbook without an extended keyboard. Remape in Macos --> Keyboard Caps Lock to Control. Now Caps Lock becomes your right Control key. In BTT you can then choose which control key to use for shortcuts.

I am still experiencing inconsistent HyperKey behavior:

  1. Sometimes when I have an input focused, caps-lock will actually toggle on and off.
  2. Often times, especially if I haven't used a hyper key in a while, I will need to trigger it multiple times before it activates.

Most of my hyper key actions just open specific apps, no external scripts or shortcuts.

Unfortunately, I have switched back to Karabiner Elements for my hyper key usage. BTT's implementation just did not work reliably.

I use a Microsoft Sculpt keyboard, which is connected through it's USB wireless dongle. Perhaps that is why? Not sure.

Hopefully future releases help stabilize it.

For who is interested.

When using BTT hyperkey to trigger macros in KM, sometimes it doesn't work. This seems to be because BTT keeps the modifier pressed for a (too) long time.

What helps is to release all modifiers at the beginning of the KM macro.

Thanks. I’m giving this release action a try over the next several days to see if it makes it more reliable for me.

It turns out releasing the modifiers made no difference. Guess I’m going back to Karabiner, which never had problems triggering. I’ve spent too many hours trying to get the BTT hyperkey working reliably. But I’ll save all my BTT hyperkey shortcuts (deactivated), in case it ever becomes reliable on my system.