HyperKey does not work with BTT

Describe the bug
I have a HyperKey (https://hyperkey.app) mapped to Capslock with following modifiers: Shift+Ctrl+Option+Cmd, but it does not seem to work with BTT. If I click a HyperKey+S instead of registering it as Shift+Ctrl+Option+Cmd+S (as in all other apps), it recognises it as Cmd+S. Typing Shift+Ctrl+Option+Cmd+S in BTT also does not help (HyperKey+S is not recognised later). All other apps (and system preferences keyboard shortcuts) work just fine.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard

Device information:

  • Type of Mac: MBP 14 Pro
  • macOS version: Monterey 12.6.1
  • BetterTouchTool version: 3.936

This can not work because the hyperkey app works at a too high level. However you can setup a hyper key in BTT:
Defining a Hyper Key · GitBook (folivora.ai)

Unfortunately BTT's Hyper Key implementation is mostly made for usage with shortcuts defined in BTT, and might sometime not work well with shortcuts defined in other apps

Oh thanks, I was not aware BTT has such functionality. I just set it up and it seems to work with my apps where I had my HyperKey defined, so very cool! It means I can uninstall HyperKey app :wink:

But how do I make use of HyperKey in BTT itself to trigger some actions ? If I add the keyboard shortcut and lets say press Capslock + S, it only recognizes it as Capslock (not HyperKey). Adding Shift+Ctrl+Option+Cmd+S in BTT won't fire the action when I press Capslock + S.

mhh that should work fine (just verified here). Maybe try to restart BTT once after setting up the hyper key functionality

Hmmm. uninstalled HyperKey, restarted BTT and still the same. Only recognises it as Capslock. Might be I have to restart my MacOS...

Recognizing caps lock is normal, however when pressing the modifiers while recording a new shortcut, BTT should trigger the action correctly after it was recorded.

LoL, ok, now I got your point. Yes, once I pressed modifiers + my key it works now after pressing the hyperkey. Idk why it did not work earlier, I guess BTT restart helped. Thx a lot for your help, issue closed :slight_smile: