Holding fn causes all modifiers to be triggered at once

Describe the bug
Holding fn causes all modifier menus to be displayed at the same time, which looks like a big mess. See screenshot.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.): Touch Bar


Device information:

  • Type of Mac: 2018 15" MBP
  • macOS version: 10.14.4 Beta
  • BetterTouchTool version: 2.719

I don't really understand the FN issue - the FN key is completely controlled by the system - or not?

fwiw, I believe this issue only started when you updated the way modifier menus behaved a while back. Perhaps that could help you isolate things? Who knows, maybe you secretly found a way to configure the fn key... :smiley:

Ah indeed, somehow it can override the fn key if "Press fn key to expand control strip" is selected. With "Show F1, F2... keys" selected it doesn't. I think this might have changed with a macOS update, but yes, this will then allow to use the FN key. I'll add it as a official modifier.

Until this is done maybe just select "Press fn key to show f1, f2, etc. Keys"

Wait, that's actually awesome! I may actually move some functions to the fn key if it works reliably...

In related news, do you have a solution for Touch Bar elements hiding when multiple modifiers are being pressed? I'd prefer if they didn't hide so you get the Home Strip instead of an empty Touch Bar.

This is the default behavior for the "show if all these modifiers are pressed" option. (Which can now in combination with the "Always show regardless of modifier" option be used to achieve the same thing you are currently doing).

However it would again require to change all the modifier options again, so better wait for the batch editing feature.

I don't see the "always show regardless of modifier" option - is it not out yet?

I don't mind updating all of the modifiers manually, since it would be a big UX boost for the preset to ignore multiple pressed modifiers.

@Andreas_Hegenberg I went through and updated all my modifier widgets and buttons. This is a lot nicer than before! However, it comes with one really annoying caveat: I have to use a spacer to hide the normal Home Strip. This would be fine, except it causes there to be a "blink" when invoking any of the menus since it overlaps with the menu bar items that have been set docked to the right to always appear.

I figure it would be easier to fix this blinking issue than to make another modifier setting, haha. Is that possible? If not, well... we'll go from there, haha. Basically, I want the home strip to hide when pressing a single modifier to make room for the modifier menus, but I don't want it to hide when pressing multiple modifiers. This is not the current behavior, but if I can have this spacer-blinking fix I can work around those limitations!

For the record, this blinking issue has been around forever, and may even be "intentional", but I have never made a big stink of it until now :stuck_out_tongue:

I wanted to fix the blinking issue for quite a while, but didn't get around do it yet :slight_smile:
I'll put it a bit higher on my TODO list :grinning:

1 Like

Cool, I just posted experimental version 2.723 if you want a build to test against for the blinking :slight_smile:

Any luck fixing the blinking issue? :slight_smile: