Give application-specific buttons priority over global ones

I recently started using the GoldenChaosBTT template. I like it so far, but one issue I have with its global buttons always take precedence over my application-specific buttons in the scrollable main touch bar. That is not desirable for me, as I naturally want to have the application-specific buttons appear before the generic ones (like music control and calendar info).

As a workaround, I have set my buttons to be fixed to the left side of the touch bar, but that causes other issues (like lack of scrollability).
Is there a way to either
a) Let application-buttons appear before global ones, or
b) disable global buttons for a specific application

1 Like

This is something I would like to see also. I would like it to be a per app setting as I sometimes like the global actions to appear first, sometimes last and sometimes not at all.

Turns out that my requested function is already available, though only globally, not per app (sorry @rkayd). Not sure how I overlooked that before.

  1. Go to General Touch Bar Settings
  2. Change the first dropdown menu from Show Global Actions Before App Specific Actions to Show Global Actions After App Specific Actions

I've just started using BTT and I found this thread but I don't see the dropdown mentioned under General Touchbar Settings ... what am I missing?

Newer versions now have a display order field that can be set per trigger. (Lower values will display left, higher values right).

I had to restart BTT to get them to show but the global ones disappeared. But, strangely, the globalones reappeared and the app specific ones now don't show. I do have GC loaded if that's pertinent ...

Right now only the global are showing despite having display orders (of -100, etc.) in the app specific settings.

I restarted BTT and now for the global I'm only seeing Escape, "Show Finder", Snap left, Snap Center, and Snap Right but the app specific show up OK then after some undetermined time or action the "real" global shows up and the app specific disappear.

I'm confused.

Which BTT version are you on?

Version: 2.687 (992)

Ah wait, does it show a globe on the left side? Maybe you accidentally enabled "global" mode by long-pressing the BTT icon in the control strip?

No, the far left shows the "escape" arrows.

Mh then I'm currently out of ideas :-/, for that BTT version I haven't had similar issue reports yet.
Maybe something wrong with your preset?

Well, something is borked because it's acting differently than it did yesterday AFAIR. I'll try rebooting first and play with it a bit. If I discover anything I'll let you know.

I think I've narrowed it down to the Group Show Browser Tabs in GC. That seems to take over the touchbar. I don't know if it's something I've messed with or it's out of the box but I've turned that off until I know more about how it all works. I'm happy with that because I'm still learning how to use this amazing tool.


Well, I guess you can chalk that up to user error. I didn't realize that the Group was modal and that I needed to dismiss it to get back to "normal" ... I'm feeling much more in control now ...

1 Like

I have same keyboard shortcut both in 'all apps' and specific application section. I would like to have application specific to be executed while that application is in focus, but one in 'all apps' gets executed. I tried to find order list being mentioned in this thread, but without success. My BTT is 3.373.

That's the default behavior and should work fine. In what app are you testing? Is it something special?

Andreas, thank you for your express response. You are greatest. And as usual, once I open support case, 3 minutes later I manged to find my mistake by myself. I was sending wrong keystroke.
Thank you so much.

1 Like

It does not work for me that way in one scenario - I have 3 finger swipe up set in All Apps to enter fullscreen and in Safari i have 3 finger swipe up to open a new Safari window. The All Apps shortcut has priority over Safari and when i use it, instead of having new Safari window opened i enter Safari fullscreen

It should definitely behave like that for Safari too, maybe something is wrong with your configuration? Can you post screenshots or export your setup?

Imprint | Privacy Policy