Dock Badges not showing

Describe the bug
After updating to Big Sur (11.0.1) dock badges stopped showing (Discord, Telegram, WhatsApp, Mail, Calendar/Fantastical, etc)
I tried disabling and re-enabling them, restarting BTT and also restarting my Macbook, all without success.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2018, 4 TB3 Ports)
  • macOS version: 11.0.1
  • BetterTouchTool version: 3.504

did they stop showing in the macOS Dock or in some custom BTT widgets?

In the Touch Bar, they still show just fine in the Dock.

Forgot to mention that I'm using the GoldenChaos BTT preset, guess that's a problem with the Dock Badges Widgets in there then?

I’ll have a look!

The dock functionality seems to work fine here on Big Sur. @GoldenChaos is this working for you?

Tried some more restarting, nothing seemed to work, so I decided to switch to AquaTouch, funnily enough the badges starting showing up as soon as I started the import.
After disabling AquaTouch and re-enabling GC they continued to work.

Not sure what exactly caused and solved this problem.

The dock functionality does not seem to work,The script editor return value is always "missing value".

Weird, seems to work fine here.

Could you check whether BTT has the permissions in System Preferences => Security & Privacy => Privacy => Accessibility? (Possibly try to remove BTT and add it back there)

Also check the permissions in System Preferences => Security & Privacy => Privacy => Automation