Disable BTT not working for Unity 3d game editor

Describe the bug

Unity 3D uses the right mouse button for 3D panning. Therefore I want to selectively disable mouse gestures. However, after adding Unity to the app list of BTT settings and selecting the Disable Drawings / Mouse Gestures mouse gestures are still active. I have tried restarting Unity and BTT, and also trying the Disable BTT completely and it is still not working.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Internal trackpad or external mouse.

Device information:

  • Type of Mac: MBP 11,5
  • macOS version: 12.1 (21C52)
  • BetterTouchTool version: 3.690

I don't have unity installed, but the general disable function for drawings seems to work fine here. Maybe Unity has some special architecture where you can not match based on just the app?

Possibly try to create a conditional activation group instead and try to match the process based on other properties:

If I set this up, according to the ruleset the editor is being matched (such a nice UI by the way!):

However if I set the disable option for that conditional group:

Screenshot 2021-12-30 at 12.56.18

Gestures still trigger. I can get them to stop by disabling BTT completely:

Screenshot 2021-12-30 at 12.58.08

This breaks my global (All apps) keyboard shortcuts however. Interestingly although my hyper key stops working, the hyper key named trigger on release still works (I have this set to trigger F18 to run Alfred).

I can also confirm that this disable option is working for other apps (I disable gestures for my browser Vivaldi, and it works fine). There is something specific to Unity causing this strange behaviour...

Could you try again with the latest update? Possibly a bug was affecting this but I'm not sure

V3.697 — disabling gestures only still not working. Disabling completely now seems to be more consistent, my hyper key trigger-on-release is also stopped. So at least the disable completely is working better (which at least personally is a step backwards as now using Alfred fails to activate).

However if I disable window snapping too, then my hyper key continues to function and mouse gestures are disabled — this somewhat funky conditional behaviour at least works for my needs :joy: ...

Screenshot 2021-12-31 at 09.56.00

This conditional effect also occurs for [disable single finger scrolling], but not for [disable single finger horizontal scrolling], if that helps detail this interaction...

do you have one or more than one presets in BTT?

I'm also having problems disabling triggers, and I found other threads with similar issues that have not received replies. Here's my post with a collection of links to similar threads: Disabling trigger doesn't work - #2 by mkoester

If I can help troubleshoot in any way, please let me know! I love BTT and would not want to be without it, so thank you for all your work.

(If crossposting like this is against forum etiquette, I apologize -- let me know and I'll delete it right away!)

I did have 2 presets (Main where I try to keep my presents and a Default which I didn't set up, but I think occasionally returns, possibly due to sync across systems?) Anyway I removed Default to keep Main only and restarted BTT, still the same behaviour where [Disable Drawings] doesn't work but [Disable Snapping] + [Disable drawing] does...