"Disable BTT for a specific app" doesn't work

Describe the bug
"Disable BTT for a specific app (Sketch App and After Effects) doesn't work.

It is super annoying because I have the window snapping the same as shortcuts that I use in this apps, which means that my windows are changing size when I want to use a shortcut.

**Affected input device MacBook Pro keyboard

Device information:

  • Type of Mac: MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports)
  • macOS version: Sierra, 10.13.5 (17F77)
  • BetterTouchTool version: newest (and older had the same issue)

This seems to work fine here.
How did you disable it?

Is the disable item checked in the app specifics??

Does the BTT icon turn grey when switching to one of the disabled apps?

I absolutely love BTT but I am having the same problem, only with modifier keys. BTT is disabled for Logic and is greyed out, but when I use a modifier key BTT touch bar shows up. I am using the GoldenChaos preset.

That is a separate issue which will be fixed in the next alpha already!
// I think you should even be able to solve it already by running this terminal command (while BTT is quit):
defaults write BTTDontUnhideTouchbarOnModifierChange YES

1 Like

Terminal sent this back

Rep argument is not a dictionary

Defaults have not been changed.

ah sorry I forgot a part :slight_smile:
defaults write com.hegenberg.BetterTouchTool BTTDontUnhideTouchbarOnModifierChange YES
should work (while BTT is quit)

@Andreas_Hegenberg thanks, it seems to work, but now I have a drawback: Every click that I do with the touchpad gesture (eg tiptap left) acts also as a normal click. So imagine that I have this gesture as a volume up trigger. Every-time I use it while having cursor on youtube video it stops and plays as I click it. It wasn't working this way before.

Any idea how to solve it? Thanks!

@pablo, that's definitely not related to that command. Maybe try to restart your BTT or maybe even Mac.

@Andreas_Hegenberg I restarted mac several times. Today I have a new mac and the same issue (tip tap results also in normal click) persists (I transfered whole system). Also the window snapping doesn't work at all.

@Andreas_Hegenberg Just to let you know: I enabled BTT for all apps and snaping and click prevention works. :slight_smile: Solved

1 Like

I also have this issue. For me, disabling BTT for a single app disables some BTT functionality while using that app (keyboard shortcuts and window snapping) but does not disable hot corners.

I implement hot corners via "Named & Other Triggers", and they still trigger when using an app for which I have checked "Disable BetterTouchTool completely".

I resort to just disabling BTT globally when using certain apps. Is there another fix?

Thank you so much! As always, BTT is essential to my life because it is so darn good. I would definitely not use a Mac without BTT.

In fact, even when I disable BTT globally, hot corner triggers still occur. Now that I think about it, I usually just close BTT entirely when using certain apps because of it.

Imprint | Privacy Policy