Deactivated BTT due to Version expired

Have you been using the BTT trial? I think there was a little date issue that caused trial versions to end early/expire today.

The check for updates should now result in a working version again.

I'm also having this issue. Not only does it really affect my efficiency (due to my gestures being disabled), I also really don't like that BetterTouchTool can be remotely disabled for no reason. It feels like an invasion of my rights, given that there's no reason for the gestures to stop working, and I expect better of a paid tool.

If a license is installed BTT versions should never expire. I think it was only the trial versions ending early due to a little date issue.

Issue resolved, it now works after doing an update.

Version 7.2.7 works fine.

After more investigation, you're correct, it was due to my trial expiring, while i do have a license i hadnt applied it after i did a fresh reinstall of MacOS, so i was using a trial.

One suggestion would be a more descriptive to explain that the trial was over rather than a version being out of date.

It was a bug :grinning: usually there is a better message for ended trials!

I have this issue too, re-downloaded, no change. It says I still have 43 days left?

I'm getting this same issue now. 23 days left of trial, no new version and BTT currently disabled because it's outdated...

Tried updating to the latest alpha version as well. same issue...

Trials working again now, but you need to install the upgrade to 3.503!

Hi there,
first of all: BBT seems to be a really nice piece of software, I am quiet enjoying it so fa. Today I got the same issue. I'm am still within the trial period (22 days left) but some minutes ago BTT reported the version would be outdated and therefore deactivated. I applied the alpha-update 3.561 (1701) but no change.

MacModel: MacBookPro16,2 (13 Inch, 2020, 4 Thunderbolt 3 ports)
macOS version: 11.3 (20E232)
BTT version: 3.561 (1701)

1 Like

Same here (32 days left) on MacBook Pro (13-inch, M1, 2020), 11.3, 3.561

I have the exact same issue. Switching to alpha doesn't help. Touch bar is not functional now due to this. I have 34 days left in the trial - which I'm for sure going to let expire before I decide to purchase :slight_smile:

I have the same issue, still 44 days until the end of the trial and nothing fix it, I already tried to update to the alpha version but same message of error all the time

Ah sorry, v3.562 will be available in about 10 minutes and fix the issue!


Just to confirm that fixes it for me. Installed the update, and clicked the 'enable BTT for all apps' menu item. Thanks, you saved me from some frustration :wink:

Can cofirm that too. The update fixed the problem. Thanks for your swift reaction!

Apologies if it is frowned upon to revive an old thread, but I'm getting the same issue now as well. BTT is showing up as deactivated, though I have 32 days of my trial still remaining.

Versions: Macbook Pro M1 (2020), Big Sur 11.5, BTT 3.570.

This is still an issue in August 2022 with version 3.837. I'm pretty sure I still days left on my trial. But it started giving this strange message after I upgraded to the latest version. I thought the latest BTT version had a bug. So I downloaded a few other versions, looking for a working one. Finally found this thread.

This makes more sense. A bad error message + bad dates. After I registered my version 3, it works fine again! Yay!

Definitely worth it to fix this. I want this project to be successful and profitable. I'm afraid this will scare away new users. Thank you for your hard work! This is an amazing app that makes MacOS not just usable but excellent (I may have switched back to Windows by now without this).

Check for updates again, it should be working now.