Clipboard manager sometime pasting text in wrong window

Describe the bug
Since 2.716 clipboard manager sometimes changes window to source application when pasting test (at least pasting as plain text).

Screenshots
Hardo to make screenshot of this

Device information:

  • Type of Mac: MacBook Pro Touchbar
  • macOS version: 10.14.3 (18D109)
  • BetterTouchTool version: 2.717 (now)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
If user will copy text in source app again, then pasting works ok in target app.

Weird, I don't think I have touched the clipboard manager at all. Any specific application this happens with?

Typically I'm copying from Numbers and pasting into Pages. Have similar workflow for years and I found this problem 1-2 BTT updated ago.

I can't find any algorithm showing when it works and when not. For sure for long time it was working OK but started to have problems with one of recent updates. Latest update to 2.718 didn't solve the problem

I think I might have an idea. It could be related to App Specific Shortcuts Lagging Behind

Could you please go to the about tab in BTT and click the "Export Debug Information" button? This will create a folder called BetterTouchToolDebug on your desktop. Would be awesome if you'd zip that & send it to andreas@folivora.ai

I think there might be some exception that doesn't happen on all systems, but the debug info might show me what's wrong.

Done 123456789012345

PS. Sorry for additional characters, but forum doesn't allow messages shorter than 20 characters :wink:

Thank you! I can see in the logs that something is wrong (BTT has problems recognizing an app switch has occurred), but unfortunately the logs are not detailed enough for this specific issue, and unfortunately even with your settings I can't reproduce it here.

I have just uploaded v2.719_alpha. I don't think it will fix the issue, but it adds a few more logs. Would be great if you could test that and send me the debug info again if it still occurs.

This bug still appears from time to time in BTT 3.209 (1386)

Any progress with this bug fix?

Is anybody reviewing this forum? Problem persists for almost a year and even no signs of working on it.

Unfortunately I haven't been able to reproduce the issue (constantly using the clipboard manager) and haven't received more related bug-reports. The only thing that seems to be important on some systems: The BTT preferences window should be closed when using the clipboard manager.

I have BTT Preferences window closed and I face this problem frequently. Today it was ca. 5 times. When it happends copying data again doesn't solve the problem. So for certain combination of source data app and destination app, problem persists. What is strange, it is not everyday. The problem makes BTT Clipboard manager unusable for me. I believe that I'm not unique and other people facing the problem are just not reporting it.
What can we do to track this issue? Maybe special BTT build with extra loging?

The current alpha has some extra logging enabled, maybe you can try to reproduce the issue with that one and send the logs to me as soon as it happens again (Help => Export Diagnostic Debug Info, andreas@folivora.ai) . Possibly these logs give me a hint about a specific application / workflow that may influence this!

OK, I will.

Imprint | Privacy Policy