App Specific Shortcuts Lagging Behind

When (somewhat) quickly Cmd + Tabbing between various apps (say, Google Chrome back to Sketch and vice versa), I've noticed recently (as in the past 2 updates perhaps) that the app specific shortcuts are lagging behind.

Let me give you an example, Shortcut A in Sketch is zoom in/out. Shortcut A in Chrome is navigate tabs left/right. When switching apps by Cmd + Tab from Sketch to Chrome and using Shortcut A once in Chrome, it will zoom in/out despite being fully in Chrome. After a few moments, it will then trigger the correct shortcut (tab navigation). Shortcut A (a scroll wheel) is mapped to "Cmd +" and "Cmd -" (directionally) in Sketch. Since Chrome also uses these default zoom shortcuts (as does most apps) , the Sketch shortcut gets triggered in Chrome until after a few lengthy moments have passed.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
I am using a multi-buttoned gaming mouse that has its various buttons mapped to unused, available keyboard keys (i.e. F19, F18, F17, etc.) So, for all intents and purposes, the computer thinks I am essentially just clicking F19, F18, etc. very fast with my fingers rather than a mouse.


Device information:

  • iMac 2017
  • Mojave 10.14
  • BetterTouchTool version: 2.717

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Waiting seems to give BTT time to catch up and fully recognize the app on its backend. The OS is correctly regconizing the app immediately upon Cmd + Tab app switch as indicated in the top left menu bar. It seems BTT is the culprit that is lagging behind. I have restarted my computer countless times and tried this with dozens of other shortcuts besides the example case I provided.


thanks for reporting. I have had one similar report recently but so far am unable to reproduce this.

It would be great if you could go to the about tab in BetterTouchTool and click the"Export Debug Information" button. This will create a folder called BetterTouchToolDebug on your Desktop, if possible please send that to with reference to this thread.

I have just uploaded v2.719_alpha. I don't think it will fix the issue, but it adds a few more logs to identify what's going wrong. Would be great if you could test that and send me the debug info if the issue still occurs in that version


Sorry for not getting back immediately. I will download the alpha and give it a shot. Thanks.
[Edit] - email sent w/ debug info using the new alpha.

I think this issue should be fixed in v2.720 alpha

Beautiful. That alpha fix worked for me on my work computer (which was the one giving me issues in the first place). Thank you so much!!!!