Click intermittently not registering


#1

Describe the bug
Clicks are not being registered despite me clicking my trackpad as normal. I've been a longtime BTT user and it only just started happening. Quitting BTT fixes the issue.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
MacBook Trackpad and Magic Trackpad, don't have a mouse to test with

Screenshots
This is a screen capture of me clicking and dragging on the Desktop. Each time the cursor is moving from one corner to another, I am clicking and dragging. You can see not all clicks are being registered.

Device information:

  • Type of Mac: MacBook Pro
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.717

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.


#2

Did you install any other mouse related app recently or did you configure some new gestures in BTT that you haven't used before?


#3

I only have two global gestures defined in BTT (and tried disabling all features in BTT I don't use) and I haven't installed any new mouse-related utilities or apps. I tried disabling all other apps that are listed in Security & Privacy > Accessibility and that didn't help either.


#4

Also tried downgrading to 2.05 and that didn't work.


#5

Yep, I don't think there has been a change in BTT that could cause this, thus downgrading probably won't help. However such issues are often caused by conflicting other apps or my malfunctioning hardware.

To rule out a trackpad problem, could you check if the BTT Live View shows any "phantom touches"? (Touches while you are not actively touching the trackpad)

Can you think of any other, maybe even non mouse related app you have recently installed and running? Problematic apps include such that listen for global keyboard, mouse or touch events.

You could also go to the about tab in BTT and click the "Export Debug Information" button. This will create a folder called BetterTouchToolDebug. The logs in that folder will allow me t o see whether clicks have actively been blocked by BTT (and why).
If possible please send that to andreas@folivora.ai


#6

I don't see any phantom touches in the live view.

The apps I use that listen for global keyboard shortcuts are ones I've used for a long time, like Launchbar or Dash. Also they are the first apps I tried quitting to see if it would fix the issue before I created post.

I installed 1Password and Zoom recently for work. Quitting 1Password doesn't fix the issue and I don't keep Zoom open if I'm not using it. There's something my work installed on my computer called "Malwarebytes" that has been installed for a couple weeks and worked with BTT without issue.


#7

Also I'm a developer, is there a way to trail some logs or something and see what else is listening to global keyboard, mouse or touch events? Console?


#8

I would first have a look at the BTT logs. (using the above described method or by going to ~/Library/Application Support/BetterTouchTool )

Intentionally blocked clicks are marked with "c00" and have a number which will tell me why BTT blocked a click.


#9

Seeing a lot of |c00|4| in the logs. What's 4 represent?


#10

4 is to ensure some gestures don't produce clicks (especially three finger clicks and four finger tap sequences). This shouldn't cause your issues however.

It could also be logged if some external hardware constantly triggers USB connect & disconnect notifications. Are you always seeing a "STDEV" log before the c00s? (Left click of MacBook trackpad not registering with external 4K monitor connected could be related)

Possibly check the macOS console.app for any constantly appearing USB related error logs


#11

I'm seeing |STDEV|6981| in the BTT logs a bunch, often before a c00.


#12

can you think of any connected usb devices that might be defective? (possibly a bad connector causing repeating connect / disconnect cycles)


#13

Ah! I had an Anker Qi charger plugged into my computer via a dongle. Disconnecting that solved the issue! My guess is that it was messing up because it's only a power USB device? Man, what a wild bug. Thanks for your help!


#14

Yeah these are always hard to find :slight_smile:
I will add a notification for such cases to BTT in one of the next versions. (these constantly disconnecting devices also cause quite a bit of cpu usage on macos)

Maybe the usb port couldn't provide enough power for the charger?