BTT touch bar not showing

It says "Tap to show customized BetterTouchTool Touch Bar" but when I tap on it, it doesn't show.

2019 MacBook 16"
Version 3.608 (1756)

do you have a custom Touch Bar configured already?

Yes. I've been using a custom Touch Bar for a couple years now and it's always worked smoothly.

Weird, is your BTT maybe disabled? (Could be by mistake or because your license might not be valid for the latest version anymore)

You can see the enabled/disabled state by clicking the BetterTouchTool menubar icon.

I don't believe that it's disabled? Where in the menu bad can I see this? It can't be an issue with the license because I remember buying a lifetime one but how can I check to make sure it's not that?

The main issue it seems to be is that the touch bar says:

Touch Bar Shot 2021-10-31 at 12.47.15 PM|690x20

But when I press on it, nothing happens.

I checked your license (by e-mail) and it's a lifetime license - so that's not the issue.

I'd try to force un-hide your Touch Bar using a keyboard shortcut. You can setup such a shortcut like this:

I tried setting up that shortcut, but I'm still getting the same issue.

It seems like if I was able to activate the widget/button shown in the screenshot I sent earlier it would show up, but even when I press it, BTT doesn't react.

I've got the exact same issue. Showed up after my BTT was updated and restarted. Any word on how to help or maybe revert to the old version of BTT until the glitch is resolved?

I also have this same issue. M1 MBP. I've been using BTT for over a year, and am getting that same Touch Bar message. Error only started happening today after I updated.

EDIT: A couple more details.

  • Restarting BTT from the menu icon also shows the following error message: "There was an issue restarting BetterTouchTool. This can usually be fixed by opening the BTTRelaunch app manually once. BTT will now show the folder that contains the BTTRelaunch app." - I've never seen this before when restarting an app.

  • Not sure if this is normal as I'v never checked, but the Activity Monitor is showing 4 instances of BetterTouchToolAppleScriptRunner.

If possible please go to Help => Export Diagnostic Debug Information and send the result to andreas@folivora.ai

Have you already tried to restart your machine?

I'm having this issue as well, non-M1 MBP (2019 intel). Same message kard32 is receiving about BTT not being able to relaunch. Additionally, though, nothing about the app is working - no gestures are recognized, no windows are snapping, etc. I tried a restart but I'll also try a software update soon

which version of macOS are you running currently?

12.0 Beta (21A5534d). Will update to 12.1 beta as soon as it downloads

I think the beta had a bug that could cause issues here, upgrading to the final 12.0.1 version or to 12.1 beta should fix it in this case

Thanks, will let you know shortly

Hm, updated to 12.1 beta but still experiencing the same error. I'll send my diagnostic to andreas@folivora.ai

EDIT: Seems to be working now, software update must have fixed it. Thanks for the help!

1 Like

Hi - confirming that updating to 12.1 beta also fixed my error. Works great now. Thank you!

I freshly installed BTT 3.670 to a brand new MBP 2020 M1 running macOS 12.1 but nothing happens when I click on it. I have a lifetime license.