BTT not active after long sleep, restart, then sais is hidden

I can't reproduce the issue yet, but I believe it might be a timing issue, thus happening only on some machines.
With 3.210 alpha I added a slider to the advanced BTT Touch Bar preferences:

it would be great if you'd try with a little higher values to see whether that helps. (Unfortunately I don't get a confirmation from macOS that the BTT Touch Bar is showing, thus BTT can just "guess".)

I'm experiencing the same problem. I've set the wait time to 10s but that doesn't seem to have resolved it. Any logs I can provide next time it happens to help troubleshoot?

Which version do you currently have installed? (I added some more changes in 3.213)

One more try: I added some more sleep related changes to 3.214 alpha, would be great if you'd check it out!

Same issue with macOS Catalina, after sleep.
Plus this morning I saw another issue: the app was totally crashed, I could not relaunch it. I tried to kill it through command-line, but it kept spanning new (crashing) processes, I had to reboot.

I updated to alpha channel, will see.

I'm running macOS Mojave and after the latest alpha and after setting the timeout at 10s it seems to have resolved it! Will update if it changes. Thanks!

Sleep issues for me persist on latest Catalina 10.15.2, running 3.214, on a MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) having tried every possible permutation of "wait before reinitializing". Extremely frustrating. Happy to help troubleshoot so I can keep my awesome new Touch Bar, but as it stands now I need to restart BTT several times a day and that's not going to work.

1 Like

you can also just assign the „toggle bettertouchtool touchbar“ action to a keyboard shortcut, then you can press that instead of restarting.

Unfortunately BTT can’t really know when the system has hidden the custom bar, thus it tries to do a „guess best“. Seems to work on ~90% of the systems, but it may never be 100% reliable.

Possibly also try to check/uncheck the „restart after sleep„ option in the general btt settings.

I have unchecked the option "Restart BTT after wake from sleep" and it always toggles this option back to on.

Same here. The option "Restart BTT after wake from sleep" is checked again every time I open the application again.

  • It's running in the back ground (not in the dock) - when I bring it up again the option is checked again.

Ah there was indeed a bug that caused this checkbox to not work in some configurations. Should be fixed in 3.215 alpha! Would be interesting if with that version you see different behavior if restart is activate or not.

I'm on 3.219, and this now appears fixed on my machine. It seems like the touch bar wakes up a bit slower from sleep, but when it does BTT is there consistently. Thank you!

I'm using 3.220 with Catalina. But even with the Restart-Option and the longest waiting period (10 s) activated, BetterTouchTool (meaning the BTT TouchBar) is often inactive. It only appears after clicking "Your BTT Touch Bar is Hidden, Click to Show" (as previously mentioned). Is there anything else I can try?

I'm on alpha channel, just updated to 3.225(1402). This problem has only gotten worse with updates, now the touchbar becomes hidden even after a minute-long sleep.

I've been experimenting this issue since a while (on Catalina, no Touch bar), and it got progressively worse. Ultimately, back from sleep, BTT was crashed, but there was no way to restart it. In task manager, I could kill all processes but one, which was spawning back indefinitely. It would even prevent computer from shutting down or restarting correctly.
Re-installing the app did not helped. But enabling "show icon in Dock" seem to help, it hasn't been crashing those 2-3 last days, so I'm keeping my fingers crossed.

Two new alpha channel updates. Now on 3.271(1448). The problem continues. Touchbar is hidden whenever the system has been sleeping or screen locked.

I am now updated to 3.276(1453) on alpha channel. The problem continues. Touchbar is hidden whenever the system has been sleeping, screen locked and after reboot. I have checked all the settings multiple times. Previous problems were on Mojave, I have now updated to Catalina. Is anyone reading these?

Unfortunately this currently can't be fixed on some systems as BTT can't influence when the bar is hidden by macOS and is not notified about it either. It seems to work on most systems with the latest versions though, but there still seem to be timing issues on a few systems.

I recommend to set a keyboard shortcut in BTT to quickly show/hide the bar. 3.280 will add some more checks but I don't believe they change much.

Your issue sounds quite weird though, I have not had other reports where it would have been hidden after screen saver. Maybe you could try to completely reset BTT by deleting ~/Library/Application Support/BetterTouchTool. Or possibly go to Help => Export Diagnostic Debug information and send it to, then I'll have a look at the logs!

Thank you for the reply! I'll try and make the keyboard shortcut and will also send you the logs. Perhaps even try full reset.

@samikki based on your logs I made some small adjustments in the latest alpha, maybe check whether they change anything for you!