BTT not active after long sleep, restart, then sais is hidden

I've been experimenting this issue since a while (on Catalina, no Touch bar), and it got progressively worse. Ultimately, back from sleep, BTT was crashed, but there was no way to restart it. In task manager, I could kill all processes but one, which was spawning back indefinitely. It would even prevent computer from shutting down or restarting correctly.
Re-installing the app did not helped. But enabling "show icon in Dock" seem to help, it hasn't been crashing those 2-3 last days, so I'm keeping my fingers crossed.

Two new alpha channel updates. Now on 3.271(1448). The problem continues. Touchbar is hidden whenever the system has been sleeping or screen locked.

I am now updated to 3.276(1453) on alpha channel. The problem continues. Touchbar is hidden whenever the system has been sleeping, screen locked and after reboot. I have checked all the settings multiple times. Previous problems were on Mojave, I have now updated to Catalina. Is anyone reading these?

Unfortunately this currently can't be fixed on some systems as BTT can't influence when the bar is hidden by macOS and is not notified about it either. It seems to work on most systems with the latest versions though, but there still seem to be timing issues on a few systems.

I recommend to set a keyboard shortcut in BTT to quickly show/hide the bar. 3.280 will add some more checks but I don't believe they change much.

Your issue sounds quite weird though, I have not had other reports where it would have been hidden after screen saver. Maybe you could try to completely reset BTT by deleting ~/Library/Application Support/BetterTouchTool. Or possibly go to Help => Export Diagnostic Debug information and send it to, then I'll have a look at the logs!

Thank you for the reply! I'll try and make the keyboard shortcut and will also send you the logs. Perhaps even try full reset.

@samikki based on your logs I made some small adjustments in the latest alpha, maybe check whether they change anything for you!