BTT Clipboard Manager hangs on open

Describe the bug
When opening the Clipboard Manager (via keyboard shortcut), all BTT UI hangs. Sometimes the HUD text appears, sometimes it is empty. I can move BTT windows but not interact with any other UI elements. I have to quit it via Activity Monitor. Other apps are not affected.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
n/a

Screenshots
n/a

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2019)
  • macOS version: 11.6.1
  • BetterTouchTool version: 3.616 (no alpha offered)

Restarting BTT and macOS doesn't help.

Is there any way to export all my configuration settings, delete the BTT plist and then re-import?

if you don’t have anything important in your clipboard history, try to delete this file: ~/Library/Application Support/BetterTouchTool/BTTClipboardManager.sqlite

(while BTT is quit)

Ahhh, wonderful! That worked perfectly. This has been annoying me for days—and it makes me realise how much I value this capability.

Thank you for such a quick response, and for such an excellent product that I use every few seconds!

Not worked for me. Haven't faced this bug until 3.617

yep. 3.616 works fine

which version of macOS are you running currently?

12.0.1 (21A559)

If you run into this again, please run this terminal command:

sample BetterTouchTool -file ~/Desktop/BetterTouchTool_sample.txt    

This will create a file called BetterTouchTool_sample on your Desktop, would be great if you'd send that to andreas@folivora.ai

Issue fixed in 3.620 (for me, at least)

I had the same problem in version 3.624 on MacOs Big Sur 11.6.
It seems to be working fine after deleting the BTTClipboardManager.sqlite file but I loosed my history and saved items =/ (I've actually made a backup of that file to try to open it elsewhere =/)

Update

  • Things are still not working correctly after deleting the BTTClipboardManager.sqlite file. App keeps crashing when I copy some things, for example, an image.

I also experience serious issues with Clipboard Manager, hanging very very often since like 2 weeks or so. Tried several things, incl. from this thread, also re-installing. Nothing helps :frowning:
Interesting it does not influence other BTT settings, all shortcuts work well, just not possible to use Clipboard Manager or het into BTT Settings.
It was working like a charm for years... Help!

(BTT v3.624 MacBookPro 16 2019 Big Sur 11.6.1)

Going by the reports this issue only seems to occur on macOS Big Sur. I'll have a closer look on my Big Sur machine soon.

Cannot confirm that this is related to Big Sur. I'm on Catalina and are facing the issue as well. Have to delete the sqlite file multiple times a day.
Though sth. changed, at least after an update to 3.624 BTT is not crashing anymore. It just doesn't open the clipboard manager when the issue occurs and the toolbar icon looks broken:
Screenshot 2021-11-23 at 16.24.43

I'm on Catalina (10.15.7 (19H1519))

--- sorry, another update: It still crashes when trying to open clipboard manager.

@Andreas_Hegenberg Just sent you a sample for this issue. By the way, this happens multiple times a day, and deleting the SQLite db is not necessary to get it working again. I quit BetterTouchTool using Activity Monitor and then re-launch and it is working again...until it happens again. In my case it happens within about 5 minutes; it is not hard to reproduce. Really frustrating because I cannot use spotlight so I have to manually open finder -> applications -> utilities -> activity monitor...all while the clipboard manager is sitting there on top of every other application, blocking the view.

macOS 11.6
3.624 (1774)

I confirm that it happens in Catalina (10.15.7) on latest BTT (3.624) too.

Will be fixed with the next update early next week.

3 Likes

Could anybody who encounters this problem go to Help => Export Diagnostic Debug Information, and send the result to andreas@folivora.ai? I have an idea what could cause this, but the debug info would help me.

Imprint | Privacy Policy